[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 21/27] failover: make sure that id always exist
From: |
Juan Quintela |
Subject: |
[PATCH v2 21/27] failover: make sure that id always exist |
Date: |
Wed, 18 Nov 2020 09:37:42 +0100 |
We check that it exist at device creation time, so we don't have to
check anywhere else.
Signed-off-by: Juan Quintela <quintela@redhat.com>
---
hw/net/virtio-net.c | 3 ---
softmmu/qdev-monitor.c | 4 ++++
2 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/hw/net/virtio-net.c b/hw/net/virtio-net.c
index ff82f1017d..c708c03cf6 100644
--- a/hw/net/virtio-net.c
+++ b/hw/net/virtio-net.c
@@ -3173,9 +3173,6 @@ static bool failover_hide_primary_device(DeviceListener
*listener,
hide = qatomic_read(&n->failover_primary_hidden);
g_free(n->primary_device_id);
n->primary_device_id = g_strdup(device_opts->id);
- if (!n->primary_device_id) {
- warn_report("primary_device_id not set");
- }
return hide;
}
diff --git a/softmmu/qdev-monitor.c b/softmmu/qdev-monitor.c
index 0e10f0466f..301089eaea 100644
--- a/softmmu/qdev-monitor.c
+++ b/softmmu/qdev-monitor.c
@@ -613,6 +613,10 @@ DeviceState *qdev_device_add(QemuOpts *opts, Error **errp)
}
if (qemu_opt_get(opts, "failover_pair_id")) {
+ if (!opts->id) {
+ error_setg(errp, "Device with failover_pair_id don't have id");
+ return NULL;
+ }
if (qdev_should_hide_device(opts)) {
if (bus && !qbus_is_hotpluggable(bus)) {
error_setg(errp, QERR_BUS_NO_HOTPLUG, bus->name);
--
2.26.2
- [PATCH v2 11/27] failover: remove standby_id variable, (continued)
- [PATCH v2 11/27] failover: remove standby_id variable, Juan Quintela, 2020/11/18
- [PATCH v2 13/27] failover: Remove memory leak, Juan Quintela, 2020/11/18
- [PATCH v2 12/27] failover: Remove primary_device_dict, Juan Quintela, 2020/11/18
- [PATCH v2 14/27] failover: simplify virtio_net_find_primary(), Juan Quintela, 2020/11/18
- [PATCH v2 15/27] failover: should_be_hidden() should take a bool, Juan Quintela, 2020/11/18
- [PATCH v2 16/27] failover: Rename function to hide_device(), Juan Quintela, 2020/11/18
- [PATCH v2 17/27] failover: virtio_net_connect_failover_devices() does nothing, Juan Quintela, 2020/11/18
- [PATCH v2 18/27] failover: Rename to failover_find_primary_device(), Juan Quintela, 2020/11/18
- [PATCH v2 19/27] failover: simplify qdev_device_add() failover case, Juan Quintela, 2020/11/18
- [PATCH v2 20/27] failover: simplify qdev_device_add(), Juan Quintela, 2020/11/18
- [PATCH v2 21/27] failover: make sure that id always exist,
Juan Quintela <=
- [PATCH v2 22/27] failover: remove failover_find_primary_device() error parameter, Juan Quintela, 2020/11/18
- [PATCH v2 23/27] failover: split failover_find_primary_device_id(), Juan Quintela, 2020/11/18
- [PATCH v2 24/27] failover: We don't need to cache primary_device_id anymore, Juan Quintela, 2020/11/18
- [PATCH v2 25/27] failover: Caller of this two functions already have primary_dev, Juan Quintela, 2020/11/18
- [PATCH v2 27/27] failover: Remove primary_dev member, Juan Quintela, 2020/11/18
- [PATCH v2 26/27] failover: simplify failover_unplug_primary, Juan Quintela, 2020/11/18
- Re: [PATCH v2 00/27] Virtio net failover fixes, Michael S. Tsirkin, 2020/11/18