[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1738507] Re: qemu sometimes stuck when booting windows 10

From: Launchpad Bug Tracker
Subject: [Bug 1738507] Re: qemu sometimes stuck when booting windows 10
Date: Sun, 10 Jan 2021 04:17:47 -0000

[Expired for QEMU because there has been no activity for 60 days.]

** Changed in: qemu
       Status: Incomplete => Expired

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  qemu sometimes stuck when booting windows 10

Status in QEMU:

Bug description:
  I am using qemu-2.10.1, or actually libvirt, to create a virtual machine, 
running microsoft windows 10 pro operating system.
  It installed fine and was actually working, however sometimes when trying to 
boot the vm, the whole boot process gets stuck.
  For some reason, it seemed to happen only when enough physical memory is 
taken so that, when booting a windows vm that has 4gb of available ram, host 
starts swapping some other processes. It is not always happening there, but 
often it happens, and I do not remember seeing any case of this happening when 
not swapping, maybe a kind of a timing issue?
  When this happens, I usually try to hard reset the machine by libvirt reset 
command or equivalent system_reset on qemu monitor, however the whole reset 
does not happen, and the command is a noop. That makes me think it is a qemu 
bug, not windows refusing operation. At the time of this event, qemu monitor 
and spice server are working correctly, are not stuck, and even doing things 
like system reset does not result in a monitor hang. It is also possible to 
quit qemu normally.
  I tried to workaround the bug by guessing what may cause it. Switched from 
bios to uefi, changed virtio-scsi to ahci temporarily, and disabled 
virtio-balloon in case it would be buggy, with no visible change.
  I will attach a libvirt log, because it contains qemu command line. I will 
also attach an example qemu backtrace.
  From what i know, both vcpu threads are working normally, at least none of 
them is stuck in a vcpu, nor deadlocked, etc. So backtrace could be different 
each time I tried to get it.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]