[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1872644] Re: MacOS host qemu-system-x86_64 -cpu host not working

From: Sitsofe Wheeler
Subject: [Bug 1872644] Re: MacOS host qemu-system-x86_64 -cpu host not working
Date: Wed, 20 Jan 2021 08:39:03 -0000

I found that things were unstable unless the following were also added
-cpu Nehalem,-rdtscp
(the CPU can be higher than Nehalem but obviously your host CPU actually has to 
be equal or greater too)

-rdtscp is a known issue that has since been workedaround (see bug
#1894836 ).

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  MacOS host qemu-system-x86_64 -cpu host not working

Status in QEMU:

Bug description:
  MacOS: 10.15.4
  uname -a: Linux door 4.15.0-96-generic #97-Ubuntu SMP Wed Apr 1 03:25:46 UTC 
2020 x86_64 x86_64 x86_64 GNU/Linux

  I am using qemu on mac host, with ubuntu client.

  I used to have "-cpu host" in my qemu command as follow:-

  qemu-system-x86_64 \
  -no-user-config \
  -nodefaults \
  -name u64d01 \
  -show-cursor \
  -M q35,accel=hvf,usb=off,vmport=off \
  -cpu host \
  -m 8192M \
  -smp 4 \
  -rtc base=utc,clock=host \
  -device virtio-blk-pci,drive=ssd1 \
  -drive id=ssd1,file=/Users/js/code/vm/qemu/u64d01.qcow2,if=none,format=qcow2 \
  -device virtio-net-pci,netdev=nic1,mac=52:54:98:76:54:33 \
  -netdev user,id=nic1,ipv4=on,ipv6=on,hostname=u64d01,hostfwd=tcp::2222-:22 \
  -device virtio-tablet-pci \
  -device virtio-vga \
  -device ich9-intel-hda,id=snd,msi=on \
  -device hda-output,id=snd-codec0,bus=snd.0,cad=0,audiodev=snd0 \
  -audiodev coreaudio,id=snd0

  Base on log of one of the vm, it was definitely working on
  2020-01-17(base on journal inside vm), with qemu 4.2.0, which I
  installed with brew.

  The only way to make it work is to remove "-cpu host".

  Already tried with 4.1.1, 4.2 and 5.0rc2. Same result.

  To reproduce, try above with a Ubuntu 18.04 installation cd. Client
  will crash during kernel loading.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]