[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: qemu broke booting of old RedHat floppies

From: Thomas Huth
Subject: Re: qemu broke booting of old RedHat floppies
Date: Wed, 20 Jan 2021 16:41:59 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.6.0

On 20/01/2021 16.11, Michael Tokarev wrote:
As someone noticed on IRC, old (2.x) RedHat floppies does not boot
in current qemu.  When qemu is booted from floppy image at
(download the "ISO image" link there, it really is an 1.44 floppy),
seabios says Boot failed and that's it.

I run git bisect with it, knowing that qemu 2.1 works fine, and
it pointed out to this commit which is oldish qemu-2.5+:
Now, I don't even know where to put that "type=144/288/auto" thing,
I tried this:

 -drive file=RedHatLinuxBootDisk521998.disk1of1.img,if=floppy,format=raw,type=144

but it says that format=raw does not support "type=144" option.


qemu-system-x86_64 -drive if=none,file=RedHatLinuxBootDisk521998.disk1of1.img,format=raw,id=dr1 -device floppy,drive-type=144,drive=dr1

And it's even more: I don't remember which size should be an 1.44Mb floppy :))
The file size of that image is 1492992 bytes which does not look like it is of
standard size, but I can't find which size it should be.

As mentioned on IRC already, it's likely a disk with 81 tracks instead of 80 tracks, so it's bigger than the usual 1.44 MB floppy disk images and thus QEMU likely misdetects it by default.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]