[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 06/16] qapi/gen: Replace ._begin_system_module()
From: |
Markus Armbruster |
Subject: |
[PULL 06/16] qapi/gen: Replace ._begin_system_module() |
Date: |
Mon, 8 Feb 2021 14:58:36 +0100 |
QAPISchemaModularCVisitor._begin_system_module() is actually just for
the builtin module. Rename it to ._begin_builtin_module() and drop
its useless @name parameter.
Clarify conditionals in visit_module to make this clear.
Signed-off-by: Markus Armbruster <armbru@redhat.com>
Signed-off-by: John Snow <jsnow@redhat.com>
Message-Id: <20210201193747.2169670-7-jsnow@redhat.com>
---
scripts/qapi/gen.py | 9 +++++----
scripts/qapi/types.py | 2 +-
scripts/qapi/visit.py | 2 +-
3 files changed, 7 insertions(+), 6 deletions(-)
diff --git a/scripts/qapi/gen.py b/scripts/qapi/gen.py
index 2aec6d3436..aaed78eed5 100644
--- a/scripts/qapi/gen.py
+++ b/scripts/qapi/gen.py
@@ -295,23 +295,24 @@ class QAPISchemaModularCVisitor(QAPISchemaVisitor):
genc.write(output_dir)
genh.write(output_dir)
- def _begin_system_module(self, name: None) -> None:
+ def _begin_builtin_module(self) -> None:
pass
def _begin_user_module(self, name: str) -> None:
pass
def visit_module(self, name: Optional[str]) -> None:
- if name is None:
+ if QAPISchemaModule.is_builtin_module(name):
if self._builtin_blurb:
- self._add_system_module(None, self._builtin_blurb)
- self._begin_system_module(name)
+ self._add_system_module(name, self._builtin_blurb)
+ self._begin_builtin_module()
else:
# The built-in module has not been created. No code may
# be generated.
self._genc = None
self._genh = None
else:
+ assert QAPISchemaModule.is_user_module(name)
self._add_user_module(name, self._user_blurb)
self._begin_user_module(name)
diff --git a/scripts/qapi/types.py b/scripts/qapi/types.py
index 2b4916cdaa..dbf58c0b91 100644
--- a/scripts/qapi/types.py
+++ b/scripts/qapi/types.py
@@ -271,7 +271,7 @@ class QAPISchemaGenTypeVisitor(QAPISchemaModularCVisitor):
prefix, 'qapi-types', ' * Schema-defined QAPI types',
' * Built-in QAPI types', __doc__)
- def _begin_system_module(self, name: None) -> None:
+ def _begin_builtin_module(self) -> None:
self._genc.preamble_add(mcgen('''
#include "qemu/osdep.h"
#include "qapi/dealloc-visitor.h"
diff --git a/scripts/qapi/visit.py b/scripts/qapi/visit.py
index 339f152152..568ba35592 100644
--- a/scripts/qapi/visit.py
+++ b/scripts/qapi/visit.py
@@ -305,7 +305,7 @@ class QAPISchemaGenVisitVisitor(QAPISchemaModularCVisitor):
prefix, 'qapi-visit', ' * Schema-defined QAPI visitors',
' * Built-in QAPI visitors', __doc__)
- def _begin_system_module(self, name: None) -> None:
+ def _begin_builtin_module(self) -> None:
self._genc.preamble_add(mcgen('''
#include "qemu/osdep.h"
#include "qapi/error.h"
--
2.26.2
- [PULL 00/16] QAPI patches patches for 2021-02-08, Markus Armbruster, 2021/02/08
- [PULL 04/16] qapi/gen: inline _wrap_ifcond into end_if(), Markus Armbruster, 2021/02/08
- [PULL 02/16] qapi/events: fix visit_event typing, Markus Armbruster, 2021/02/08
- [PULL 12/16] qapi/gen: Support switching to another module temporarily, Markus Armbruster, 2021/02/08
- [PULL 01/16] qapi/commands: assert arg_type is not None, Markus Armbruster, 2021/02/08
- [PULL 13/16] qapi/commands: Simplify command registry generation, Markus Armbruster, 2021/02/08
- [PULL 07/16] qapi: use explicitly internal module names, Markus Armbruster, 2021/02/08
- [PULL 03/16] qapi/main: handle theoretical None-return from re.match(), Markus Armbruster, 2021/02/08
- [PULL 06/16] qapi/gen: Replace ._begin_system_module(),
Markus Armbruster <=
- [PULL 05/16] qapi: centralize is_[user|system|builtin]_module methods, Markus Armbruster, 2021/02/08
- [PULL 16/16] qapi: enable strict-optional checks, Markus Armbruster, 2021/02/08
- [PULL 11/16] qapi/gen: write _genc/_genh access shims, Markus Armbruster, 2021/02/08
- [PULL 15/16] qapi: type 'info' as Optional[QAPISourceInfo], Markus Armbruster, 2021/02/08
- [PULL 10/16] qapi: centralize the built-in module name definition, Markus Armbruster, 2021/02/08
- [PULL 14/16] qapi/gen: Drop support for QAPIGen without a file name, Markus Armbruster, 2021/02/08
- [PULL 09/16] qapi/gen: Combine ._add_[user|system]_module, Markus Armbruster, 2021/02/08
- [PULL 08/16] qapi: use './builtin' as the built-in module name, Markus Armbruster, 2021/02/08
- Re: [PULL 00/16] QAPI patches patches for 2021-02-08, Peter Maydell, 2021/02/08