[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: supported machines for aarch64

From: Philippe Mathieu-Daudé
Subject: Re: supported machines for aarch64
Date: Mon, 15 Feb 2021 08:38:18 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.7.0


On 2/15/21 6:26 AM, ckim@etri.re.kr wrote:
> Hello,
> I tried “qemu-system-arm –machine help” and it gave me 75 machines.
> Then I tried “qemu-system-aarch64 –machine help”, and it gave me almost
> the same result except it had raspi3, sbsa-ref, xlnx-versal-virt and
> xlnx-zcu102 in addition.
> I asked myself, Does this mean most machines work both in 32bit mode and
> 64bit mode and those added 4 machines work only in 64bit mode?


> So I tried for integrator machine which is supported both by
> qemu-system-arm and qemu-system-aarch64,
> “qemu-system-arm –machine integrator –cpu help” and “qemu-system-aarch64
> –machine integrator –cpu help”, and this time,
> The cpu list was almost the same(mostly seemd older 32 bit versions) but
> the aarch64 cpu list gave me 3 more cpus (cortex-a53, a57 and a72).


> So I realized the qemu-system-aarch64 can emulate both 32bit and 64bit
> machine and cpu cores – as the document says.


> .(it’s still strange “qemu-system-arm –machine help” doesn’t give me
> xlnx-versal-virt in the list, but “qemu-system-arm –machine
> xlnx-versal-virt –cpu help” still gives some machines in the list..)

This is because '-cpu' is processed *before* '-machine', so this works:

$ qemu-system-arm -M adsfafdadsfasdfdafadfasdfa -cpu help
Available CPUs:

> I started this as a question but found out the answer while writing..


> Thank you and correct me if I’m wrong



reply via email to

[Prev in Thread] Current Thread [Next in Thread]