[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 00/13] target/mips: Replace integer by MMUAccessType enum whe
From: |
Philippe Mathieu-Daudé |
Subject: |
Re: [PATCH 00/13] target/mips: Replace integer by MMUAccessType enum when possible |
Date: |
Sun, 21 Feb 2021 09:33:49 +0100 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.7.0 |
On 1/28/21 3:41 PM, Philippe Mathieu-Daudé wrote:
> Taking notes while reviewing commit 671a0a1265a
> ("use MMUAccessType instead of int in mmu_translate").
>
> Philippe Mathieu-Daudé (13):
> target/mips: Remove access_type argument from map_address() handler
> target/mips: Remove access_type argument from get_seg_physical_address
> target/mips: Remove access_type arg from get_segctl_physical_address()
> target/mips: Remove access_type argument from get_physical_address()
> target/mips: Remove unused MMU definitions
> target/mips: Replace magic value by MMU_DATA_LOAD definition
> target/mips: Let page_table_walk_refill() take MMUAccessType argument
> target/mips: Let do_translate_address() take MMUAccessType argument
> target/mips: Let cpu_mips_translate_address() take MMUAccessType arg
> target/mips: Let raise_mmu_exception() take MMUAccessType argument
> target/mips: Let get_physical_address() take MMUAccessType argument
> target/mips: Let get_seg*_physical_address() take MMUAccessType arg
> target/mips: Let CPUMIPSTLBContext::map_address() take MMUAccessType
>
> target/mips/cpu.h | 16 ---------
> target/mips/internal.h | 10 +++---
> target/mips/op_helper.c | 9 ++---
> target/mips/tlb_helper.c | 78 +++++++++++++++++++---------------------
> 4 files changed, 47 insertions(+), 66 deletions(-)
Thanks, patches 1-6 and 8-13 applied to mips-next.