[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1916344] Re: User mode networking not working properly on QEMU on M

From: John Arbuckle
Subject: [Bug 1916344] Re: User mode networking not working properly on QEMU on Mac OS X host
Date: Mon, 22 Feb 2021 01:21:16 -0000

I built QEMU from the git repo. My Windows XP and Mac OS 10.4 guests
cannot access the internet. I'm on a M1 Mac running Mac OS 11.1. I use
qemu-system-i386 and qemu-system-ppc.

I tried installing slirp from MacPorts but it is broken. It might have
been broken for years. See https://trac.macports.org/ticket/41875. So
slirp networking probably isn't going to work.

** Bug watch added: trac.macports.org #41875

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  User mode networking not working properly on QEMU on Mac OS X host

Status in QEMU:

Bug description:
  Steps to reproduce:

  1. Install QEMU using homebrew on Mac OS X (I tried on Catalina and Big Sur)
  2. Spin up a guest VM (say) Cent OS 8 using user mode networking.
  3. Install podman inside the guest
  4. Run podman pull alpine

  The result is:

  [root@localhost ~]# podman pull alpine
  Resolved "alpine" as an alias 
  Trying to pull docker.io/library/alpine:latest...
  Getting image source signatures
  Copying blob ba3557a56b15 [======================================] 2.7MiB / 
    unexpected EOF
  Error: Error writing blob: error storing blob to file 
"/var/tmp/storage851171596/1": error happened during read: unexpected EOF

  This is happening because QEMU is telling the guest that the TCP
  connection is closed even before reading all the data from the host
  socket and forwarding it to the guest.

  This issue doesn't happen on a Linux host. So, that tells me that this
  has something to do with QEMU installation on Mac OS X.

  This could be a slirp related issue. So, QEMU/slirp may need to work
  together on fixing this. Here's the link to the libslirp issue:


To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]