[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1836501] Re: cpu_address_space_init fails with assertion

From: Ravishankar
Subject: [Bug 1836501] Re: cpu_address_space_init fails with assertion
Date: Mon, 22 Feb 2021 05:48:02 -0000

When I use gdb i see that the assert line uses:

   /* KVM cannot currently support multiple address spaces. */
    assert(asidx == 0 || !kvm_enabled());

the asidx is 1. So since KVM is not supporting multiple addresses spaces
that the Raspi3 requires the assertion occurs.

I wonder what the workaround could be for this

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  cpu_address_space_init fails with assertion

Status in QEMU:

Bug description:
  qemu-system-arm does not start with version >= 2.6 and KVM enabled.

    cpu_address_space_init: Assertion `asidx == 0 || !kvm_enabled()'

  Hardware is Odroid XU4 with Exynos with 4.9.61+ Tested with Debian
  Stretch (9) or Buster (10).

  Without KVM it is running fine but slow. I'm operating Debian Jessie
  with qemu 2.1 for a long time with KVM virtualization working
  flawlessly. When I upgraded to Stretch I ran into the trouble
  described before. I tried Debian Stretch and Buster with all Kernels
  provided by the Board manufacturer (Hardkernel).

  It seems to be related to the feature introduced in Version 2.6:
  - Support for a separate EL3 address space

  KVM is enabled, so I assume the adress space index asidx to be causing
  the assert to fail.

  dmesg | grep -i KVM
  [    0.741714] kvm [1]: 8-bit VMID
  [    0.741721] kvm [1]: IDMAP page: 40201000
  [    0.741729] kvm [1]: HYP VA range: c0000000:ffffffff
  [    0.742543] kvm [1]: Hyp mode initialized successfully
  [    0.742600] kvm [1]: vgic-v2@10484000
  [    0.742924] kvm [1]: vgic interrupt IRQ16
  [    0.742943] kvm [1]: virtual timer IRQ60

  Full command line is:
  qemu-system-arm -M vexpress-a15 -smp 2 -m 512 -cpu host -enable-kvm -kernel 
vmlinuz -initrd initrd.gz -dtb vexpress-v2p-ca15-tc1.dtb -device 
virtio-blk-device,drive=inst-blk -drive 
file=PATHTOFILE,id=inst-blk,if=none,format=raw -append "vga=normal rw 
console=ttyAMA0" -nographic

  Is there anything to do to understand, if this is a hardware related
  failure or probably just a missing parameter?



To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]