qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 01/13] net: eth: Add a helper to pad a short ethernet fram


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH v3 01/13] net: eth: Add a helper to pad a short ethernet frame
Date: Tue, 16 Mar 2021 09:49:45 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.8.0

On 3/16/21 9:12 AM, Bin Meng wrote:
> Add a helper to pad a short ethernet frame to the minimum required
> length, which can be used by backend codes.
> 
> Signed-off-by: Bin Meng <bmeng.cn@gmail.com>
> 
> ---
> 
> Changes in v3:
> - use 'without' instead of 'sans'
> - add a helper to pad short frames
> 
>  include/net/eth.h | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/include/net/eth.h b/include/net/eth.h
> index 0671be6916..bc064f8e52 100644
> --- a/include/net/eth.h
> +++ b/include/net/eth.h
> @@ -31,6 +31,31 @@
>  
>  #define ETH_ALEN 6
>  #define ETH_HLEN 14
> +#define ETH_ZLEN 60     /* Min. octets in frame without FCS */
> +
> +/**
> + * pad_short_frame - pad a short frame to the minimum ethernet frame length
> + *
> + * If the ethernet frame size is shorter than 60 bytes, it will be padded to
> + * 60 bytes at the address @min_pkt.
> + *
> + * @min_pkt: buffer address to hold the padded frame
> + * @pkt: address to hold the original ethernet frame
> + * @size: size of the original ethernet frame
> + * @return true if the frame is padded, otherwise false
> + */
> +static inline bool pad_short_frame(uint8_t *min_pkt, const uint8_t *pkt,
> +                                   int size)
> +{
> +    if (size < ETH_ZLEN) {
> +        /* pad to minimum ethernet frame length */
> +        memcpy(min_pkt, pkt, size);
> +        memset(&min_pkt[size], 0, ETH_ZLEN - size);
> +        return true;
> +    }
> +
> +    return false;
> +}

I don't want to be too nitpicky but since I'm Cc'ed...

- 'ethernet' -> 'Ethernet'

- I'm not sure inlining is justified

- The same function is used for 2 different operations,
  . check if padding is required
  . do the padding

- If we provide a function a buffer to fill, we need to check the
  buffer size is big enough to avoid overflow

What about something like:

  bool pad_short_frame(char *padded_pkt, size_t *padded_buflen,
                       const void *pkt, size_t pkt_size);
  {
      assert(padded_buflen && *padded_buflen >= ETH_ZLEN);
      if (src_size >= ETH_ZLEN) {
          return false;
      }
      /* pad to minimum ethernet frame length */
      memcpy(padded_pkt, pkt, pkt_size);
      memset(&padded_pkt[pkt_size], 0, ETH_ZLEN - padded_buflen);
      *padded_buflen = ETH_ZLEN;

      return true;
  }

What do you think?




reply via email to

[Prev in Thread] Current Thread [Next in Thread]