qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: usb-host device not working


From: Programmingkid
Subject: Re: usb-host device not working
Date: Tue, 13 Jul 2021 10:51:06 -0400


> On Jul 13, 2021, at 10:49 AM, Programmingkid <programmingkidx@gmail.com> 
> wrote:
> 
> I have been having problems with using host USB devices lately. I use to be 
> able to use host USB devices but can't currently. After doing some git 
> bisecting I found it was this patch that causes this issue:
> 
> commit 627302afb2f85cdd4b59595361876487aef19b7a (refs/bisect/bad)
> Author: Gerd Hoffmann <kraxel@redhat.com>
> Date:   Thu Jun 24 12:38:35 2021 +0200
> 
>    usb: build usb-host as module
> 
>    Drop one more shared library dependency (libusb) from core qemu.
> 
>    Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
>    Reviewed-by: Jose R. Ziviani <jziviani@suse.de>
>    Message-Id: <20210624103836.2382472-34-kraxel@redhat.com>
>    Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
> 
> I build QEMU like this:
> 
> ./configure --target-list=i386-softmmu --enable-libusb && make -j 9
> 
> This command use to work but fails now with the above commit:
> 
> qemu-system-i386 -usb -device usb-host,vendorid=0x093a,productid=0x2510
> 
> I think this is a bug with the commit. Any suggestions?
> 
> Thank you.

Forgot to mention this issue is observed on Mac OS 11.1.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]