[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PULL v4 00/42] testing, build and plugin updates

From: Peter Maydell
Subject: Re: [PULL v4 00/42] testing, build and plugin updates
Date: Tue, 13 Jul 2021 17:51:06 +0100

On Mon, 12 Jul 2021 at 22:05, Alex Bennée <alex.bennee@linaro.org> wrote:
> The following changes since commit bd38ae26cea0d1d6a97f930248df149204c210a2:
>   Merge remote-tracking branch 'remotes/rth-gitlab/tags/pull-tcg-20210710' 
> into staging (2021-07-12 11:02:39 +0100)
> are available in the Git repository at:
>   https://github.com/stsquad/qemu.git tags/pull-testing-and-plugins-120721-4
> for you to fetch changes up to 312ad3f702789db630c8e43aaad718a1459b2018:
>   MAINTAINERS: Added myself as a reviewer for TCG Plugins (2021-07-12 
> 20:13:24 +0100)
> ----------------------------------------------------------------
> Testing and plugin updates:
>   - custom runner playbooks for configuring GitLab runners
>   - integrate Cirrus jobs into GitLab via cirrus-run
>   - clean-up docker package lists
>   - bump NetBSD to 9.2
>   - bump OpenBSD to 6.9
>   - make test-mmap more hexagon friendly
>   - fixup handling of hostaddr for plugins
>   - disallow some incompatible plugin configurations
>   - enable plugins by default for most TCG builds
>   - honour main build -Wall settings for plugins
>   - new execlog plugin
>   - new cache modelling plugin
>   - fix io_uring build regression
>   - disable modular TCG on Darwin

Fails to build, OSX, when trying to link qemu-system-alpha-unsigned:

Undefined symbols for architecture x86_64:
  "_qemu_plugin_hwaddr_to_raddr", referenced from:
     -exported_symbol[s_list] command line option
  "_qemu_plugin_ram_addr_from_host", referenced from:
     -exported_symbol[s_list] command line option
  "_qemu_plugin_register_vcpu_mem_haddr_cb", referenced from:
     -exported_symbol[s_list] command line option
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Fails to build, NetBSD and OpenBSD VMs:

Run-time dependency zlib found: YES 1.2.10
Run-time dependency liburing found: NO (tried pkgconfig)
Run-time dependency libxml-2.0 found: YES 2.9.12
Run-time dependency libnfs found: NO (tried pkgconfig)
Run-time dependency appleframeworks found: NO (tried framework)
Run-time dependency libseccomp found: NO (tried pkgconfig)
Has header "cap-ng.h" : NO
Run-time dependency xkbcommon found: YES 1.1.0
Library rt found: YES

../src/meson.build:458:2: ERROR: C shared or static library 'dl' not found

A full log can be found at

ERROR: meson setup failed

Also, the Gitlab CI pipeline page has some odd "manual action"
items in the pipeline and some of the jobs hit the 1 hour timeout,
eg: https://gitlab.com/qemu-project/qemu/-/jobs/1420815244

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]