qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH for-6.2 v2 02/11] machine: Make smp_parse generic enough for


From: Daniel P . Berrangé
Subject: Re: [PATCH for-6.2 v2 02/11] machine: Make smp_parse generic enough for all arches
Date: Mon, 19 Jul 2021 17:36:39 +0100
User-agent: Mutt/2.0.7 (2021-05-04)

On Mon, Jul 19, 2021 at 06:28:46PM +0200, Andrew Jones wrote:
> On Mon, Jul 19, 2021 at 11:20:34AM +0800, Yanan Wang wrote:
> > Currently the only difference between smp_parse and pc_smp_parse
> > is the support of multi-dies and the related error reporting code.
> > With an arch compat variable "bool smp_dies_supported", we can
> > easily make smp_parse generic enough for all arches and the PC
> > specific one can be removed.
> > 
> > Making smp_parse() generic enough can reduce code duplication and
> > ease the code maintenance, and also allows extending the topology
> > with more arch specific members (e.g., clusters) in the future.
> > 
> > No functional change intended.
> > 
> > Suggested-by: Andrew Jones <drjones@redhat.com>
> > Signed-off-by: Yanan Wang <wangyanan55@huawei.com>
> > ---
> >  hw/core/machine.c   | 28 ++++++++++-------
> >  hw/i386/pc.c        | 76 +--------------------------------------------
> >  include/hw/boards.h |  1 +
> >  3 files changed, 19 insertions(+), 86 deletions(-)
> > 
> > diff --git a/hw/core/machine.c b/hw/core/machine.c
> > index d73daa10f4..ed6712e964 100644
> > --- a/hw/core/machine.c
> > +++ b/hw/core/machine.c
> > @@ -743,6 +743,7 @@ void machine_set_cpu_numa_node(MachineState *machine,
> >  
> >  static void smp_parse(MachineState *ms, SMPConfiguration *config, Error 
> > **errp)
> >  {
> > +    MachineClass *mc = MACHINE_GET_CLASS(ms);
> >      unsigned cpus    = config->has_cpus ? config->cpus : 0;
> >      unsigned sockets = config->has_sockets ? config->sockets : 0;
> >      unsigned dies    = config->has_dies ? config->dies : 1;
> > @@ -761,7 +762,7 @@ static void smp_parse(MachineState *ms, 
> > SMPConfiguration *config, Error **errp)
> >          return;
> >      }
> >  
> > -    if (dies > 1) {
> > +    if (!mc->smp_dies_supported && dies > 1) {
> 
> Won't this allow a user on an arch with !mc->smp_dies_supported to specify
> dies=1?

Conceptually that is fine. Before the introduction of CPU sockets
with 2+ dies, you can credibly say that all sockets had 1 die, so
it is nreasonable for users to say -smp ....,dies=1,....

libvirt will unconditionally set dies=1 for all QEMU targets if
the user didn't specify an explicit dies value

>          To not allow that, can we do
> 
>    if (!mc->smp_dies_supported && config->has_dies)
> 
> instead?

I don't see that this is benefitting apps/users.


Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|




reply via email to

[Prev in Thread] Current Thread [Next in Thread]