qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH for-6.2] hw/intc/arm_gicv3_its: Revert version increments in


From: Peter Maydell
Subject: Re: [PATCH for-6.2] hw/intc/arm_gicv3_its: Revert version increments in vmstate_its
Date: Mon, 22 Nov 2021 18:04:52 +0000

On Mon, 22 Nov 2021 at 17:10, Eric Auger <eric.auger@redhat.com> wrote:
>
> Commit 18f6290a6a ("hw/intc: GICv3 ITS initial framework")
> incremented version_id and minimum_version_id fields of
> VMStateDescription vmstate_its. This breaks the migration between
> 6.2 and 6.1 with the following message:
>
> qemu-system-aarch64: savevm: unsupported version 1 for 'arm_gicv3_its' v0
> qemu-system-aarch64: load of migration failed: Invalid argument
>
> Revert that change.
>
> Signed-off-by: Eric Auger <eric.auger@redhat.com>
> ---
>  hw/intc/arm_gicv3_its_common.c | 2 --
>  1 file changed, 2 deletions(-)
>
> diff --git a/hw/intc/arm_gicv3_its_common.c b/hw/intc/arm_gicv3_its_common.c
> index 7d7f3882e76..90b85f1e25c 100644
> --- a/hw/intc/arm_gicv3_its_common.c
> +++ b/hw/intc/arm_gicv3_its_common.c
> @@ -50,8 +50,6 @@ static int gicv3_its_post_load(void *opaque, int version_id)
>
>  static const VMStateDescription vmstate_its = {
>      .name = "arm_gicv3_its",
> -    .version_id = 1,
> -    .minimum_version_id = 1,
>      .pre_save = gicv3_its_pre_save,
>      .post_load = gicv3_its_post_load,
>      .priority = MIG_PRI_GICV3_ITS,

Oops, I didn't notice that the version bump lines were still
in the patchset I applied :-(

Reviewed-by: Peter Maydell <peter.maydell@linaro.org>

-- PMM



reply via email to

[Prev in Thread] Current Thread [Next in Thread]