qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 6/7] hw/isa/piix4: Replace some magic IRQ constants


From: Michael S. Tsirkin
Subject: Re: [PATCH v3 6/7] hw/isa/piix4: Replace some magic IRQ constants
Date: Thu, 17 Feb 2022 01:35:25 -0500

On Wed, Feb 16, 2022 at 11:45:18PM +0100, Bernhard Beschow wrote:
> This is a follow-up on patch "malta: Move PCI interrupt handling from
> gt64xxx_pci to piix4". gt64xxx_pci used magic constants, and probably
> didn't want to use piix4-specific constants. Now that the interrupt
> handing resides in piix4, its constants can be used.
> 
> Signed-off-by: Bernhard Beschow <shentey@gmail.com>

Acked-by: Michael S. Tsirkin <mst@redhat.com>

> ---
>  hw/isa/piix4.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/hw/isa/piix4.c b/hw/isa/piix4.c
> index 2e9b5ccada..f876c71750 100644
> --- a/hw/isa/piix4.c
> +++ b/hw/isa/piix4.c
> @@ -61,10 +61,10 @@ static void piix4_set_irq(void *opaque, int irq_num, int 
> level)
>      /* now we change the pic irq level according to the piix irq mappings */
>      /* XXX: optimize */
>      pic_irq = s->dev.config[PIIX_PIRQCA + irq_num];
> -    if (pic_irq < 16) {
> +    if (pic_irq < ISA_NUM_IRQS) {
>          /* The pic level is the logical OR of all the PCI irqs mapped to it. 
> */
>          pic_level = 0;
> -        for (i = 0; i < 4; i++) {
> +        for (i = 0; i < PIIX_NUM_PIRQS; i++) {
>              if (pic_irq == s->dev.config[PIIX_PIRQCA + i]) {
>                  pic_level |= pci_bus_get_irq_level(bus, i);
>              }
> @@ -315,7 +315,7 @@ DeviceState *piix4_create(PCIBus *pci_bus, ISABus 
> **isa_bus, I2CBus **smbus)
>                                 NULL, 0, NULL);
>      }
>  
> -    pci_bus_irqs(pci_bus, piix4_set_irq, pci_slot_get_pirq, s, 4);
> +    pci_bus_irqs(pci_bus, piix4_set_irq, pci_slot_get_pirq, s, 
> PIIX_NUM_PIRQS);
>  
>      return dev;
>  }
> -- 
> 2.35.1
> 
> 
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]