qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v10 2/9] KVM: Introduce per-page memory attributes


From: Sean Christopherson
Subject: Re: [PATCH v10 2/9] KVM: Introduce per-page memory attributes
Date: Fri, 13 Jan 2023 22:02:11 +0000

On Fri, Dec 02, 2022, Chao Peng wrote:
> diff --git a/arch/x86/kvm/Kconfig b/arch/x86/kvm/Kconfig
> index fbeaa9ddef59..a8e379a3afee 100644
> --- a/arch/x86/kvm/Kconfig
> +++ b/arch/x86/kvm/Kconfig
> @@ -49,6 +49,7 @@ config KVM
>       select SRCU
>       select INTERVAL_TREE
>       select HAVE_KVM_PM_NOTIFIER if PM
> +     select HAVE_KVM_MEMORY_ATTRIBUTES

I would prefer to call this KVM_GENERIC_MEMORY_ATTRIBUTES.  Similar to
KVM_GENERIC_HARDWARE_ENABLING, ARM does need/have hardware enabling, it just
doesn't want KVM's generic implementation.  In this case, pKVM does support 
memory
attributes, but uses stage-2 tables to track ownership and doesn't need/want the
overhead of the generic implementation.

>       help

...

> +#define KVM_MEMORY_ATTRIBUTE_READ              (1ULL << 0)
> +#define KVM_MEMORY_ATTRIBUTE_WRITE             (1ULL << 1)
> +#define KVM_MEMORY_ATTRIBUTE_EXECUTE           (1ULL << 2)
> +#define KVM_MEMORY_ATTRIBUTE_PRIVATE           (1ULL << 3)

I think we should carve out bits 0-2 for RWX, but I don't think we should 
actually
define them until they're actually accepted by KVM.

> +static int kvm_vm_ioctl_set_mem_attributes(struct kvm *kvm,
> +                                        struct kvm_memory_attributes *attrs)
> +{
> +     gfn_t start, end;
> +     unsigned long i;
> +     void *entry;
> +     u64 supported_attrs = kvm_supported_mem_attributes(kvm);
> +
> +     /* flags is currently not used. */
> +     if (attrs->flags)
> +             return -EINVAL;
> +     if (attrs->attributes & ~supported_attrs)

Nit, no need for "supported_attrs", just consume kvm_supported_mem_attributes()
directly.

> +             return -EINVAL;
> +     if (attrs->size == 0 || attrs->address + attrs->size < attrs->address)
> +             return -EINVAL;
> +     if (!PAGE_ALIGNED(attrs->address) || !PAGE_ALIGNED(attrs->size))
> +             return -EINVAL;
> +
> +     start = attrs->address >> PAGE_SHIFT;
> +     end = (attrs->address + attrs->size - 1 + PAGE_SIZE) >> PAGE_SHIFT;
> +
> +     entry = attrs->attributes ? xa_mk_value(attrs->attributes) : NULL;
> +
> +     mutex_lock(&kvm->lock);

Peeking forward multiple patches, this needs to take kvm->slots_lock, not 
kvm->lock.
There's a bug in the lpage_disallowed patch that I believe can most easily be
solved by making this mutually exclusive with memslot changes.

When a memslot is created, KVM needs to walk through the attributes to detect
whether or not the attributes are identical for the entire slot.  To avoid 
races,
that means taking slots_lock.

The alternative would be to query the attributes when adjusting the hugepage 
level
and avoid lpage_disallowed entirely, but in the (very brief) time I've thought
about this I haven't come up with a way to do that in a performant manner.

> +     for (i = start; i < end; i++)

Curly braces needed on the for-loop.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]