[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] help using qemu to emulate raspberry pi2

From: James
Subject: [Qemu-discuss] help using qemu to emulate raspberry pi2
Date: Sun, 9 Aug 2015 05:47:09 +0000 (UTC)
User-agent: Loom/3.14 (http://gmane.org/)

I need help using qemu to emulate a raspberry pi2.
I downloaded the latest Raspian OS and tried the following command:

qemu-system-arm -kernel kernel-qemu -cpu arm1176 -m 256 -M versatilepb
-serial stdio -append "console=ttyAMA0 root=/dev/sda2" -hda
./2015-05-05-raspbian-wheezy.img -clock dynticks

It seems to boot but gets stuck in a loop.
The QEMU window loops over the login prompt and keeps showing a login prompt.
The host terminal I ran it from just shows 1 login prompt.
The QEMU window eventually shows the error:
init: Id "1" respawning too fast: disabled for 5 minutes.

If I attempt to login at this point, it shows me the passwd prompt and I can
log in and see the banner but then it goes right back to the login prompt (I
tried a wrong passwd and got different  behaviour so I know I have the right

Raspbian GNU/Linux 7 (none) ttyAMA0

(none) login: pi
Linux (none) 3.2.0 #1 Sun Jan 29 03:14:15 CST 2012 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

NOTICE: the software on this Raspberry Pi has not been fully configured.
Please run 'sudo raspi-config'

Raspbian GNU/Linux 7 (none) ttyAMA0

(none) login:

QEMU emulator version 2.3.0, Copyright (c) 2003-2008 Fabrice Bellard
usage: qemu-system-arm [options] [disk_image]

reply via email to

[Prev in Thread] Current Thread [Next in Thread]