[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Windows-10 virtualization and nested virtualization

From: Jeff Forbes
Subject: [Qemu-discuss] Windows-10 virtualization and nested virtualization
Date: Mon, 4 Apr 2016 20:08:46 +0000

We have a Windows-10 application which uses a virtual as part of the
process. I am trying to get the application to work in a virtual
environment, which of course will require nested        virtualization.

Using a libvirt xml description for a RHEL virtual where nested 
        virtualization works, I installed windows-10, Hyper-v and the
application software under the latest updates of Fedora 22.
Windows-10 works great; however, VMBus device required for Hyper-V to
work would not start and was flagged in the Device Manager. Trying to
start a virtual resulted in the error that a component required by
Hyper-V failed to start.

I then ported the VM to VMWare Workstation 12 and in this environment t
he VMBus device starts and nested virtuals start as expected. These
results indicated that the VM was working correctly and the problem was
likely with the QEMU-KVM hypervisor.

Reading recent messages on the KVM and QEMU mail lists indicated that
there were many KVM updates made to the 4.6.0-rc1 kernel, so I
download, compiled and installed this kernel. I also cloned the latest
version of qemu. When I run my Windows-10 VM in this environment with
the latest updates. the VMBus device starts and there are not warnings
in the Device Manager; however, the nested VMs do not start and the
same error about a component required by Hyper-V failed to start.

Do I need to turn something on to get this to work or is the Hyper-V
support still under development?

Please advise.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]