[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Windows-10 virtualization and nested virtualization

From: Paolo Bonzini
Subject: Re: [Qemu-discuss] Windows-10 virtualization and nested virtualization
Date: Wed, 6 Apr 2016 18:11:30 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.6.0

On 06/04/2016 17:27, Jeff Forbes wrote:
> When I use "-cpu host,+VMX,-hypervisor", Hyper-V gives this error
> when trying to start a VM: Virtual Machine could not be started
> because the hypervisor is not running.
> So with the latest kernel and qemu-kvm, the hypervisor flag is
> needed.

That is not what the error means.  The error means that Hyper-V has
failed to start.


> On Mon, 2016-04-04 at 17:35 -0400, Bandan Das wrote:
>> Jeff Forbes <address@hidden <mailto:address@hidden>> writes:
>>> We have a Windows-10 application which uses a virtual as part of the
>>> process. I am trying to get the application to work in a virtual
>>> environment, which of course will require nested virtualization.
>>> Using a libvirt xml description for a RHEL virtual where nested
>>> virtualization works, I installed windows-10, Hyper-v and the
>>> application software under the latest updates of Fedora 22.
>>> Windows-10 works great; however, VMBus device required for Hyper-V to
>>> work would not start and was flagged in the Device Manager. Trying to
>>> start a virtual resulted in the error that a component required by
>>> Hyper-V failed to start. I then ported the VM to VMWare Workstation
>>> 12 and in this environment t he VMBus device starts and nested
>>> virtuals start as expected. These results indicated that the VM was
>>> working correctly and the problem was likely with the QEMU-KVM
>>> hypervisor. Reading recent messages on the KVM and QEMU mail lists
>>> indicated that there were many KVM updates made to the 4.6.0-rc1
>>> kernel, so I download, compiled and installed this kernel. I also
>>> cloned the latest version of qemu. When I run my Windows-10 VM in
>>> this environment with the latest updates. the VMBus device starts and
>>> there are not warnings in the Device Manager; however, the nested VMs
>>> do not start and the same error about a component required by Hyper-V
>>> failed to start. Do I need to turn something on to get this to work
>>> or is the Hyper-V support still under development? 
>> I am not sure if anyone has been successful with running Hyper-V nested.
>> The first obstacle I remember is Hyper-V refusing to run when it finds
>> the "hypervisor" flag in guest cpu. If you are past that step,  maybe
>> the vmbus dependency is something else.
>>> Please advise. Best, Jeff-- To unsubscribe from this list: send the
>>> line "unsubscribe kvm" in the body of a message to
>>> address@hidden <mailto:address@hidden> More
>>> majordomo info at http://vger.kernel.org/majordomo-info.html 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]