[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] versatilepb default network adapter

From: Tom Cook
Subject: [Qemu-discuss] versatilepb default network adapter
Date: Mon, 10 Jul 2017 13:34:14 +0100

I'm using the qemu versatilepb machine to emulate a raspberry pi for
testing purposes.

I'm starting qemu with this commandline:

qemu-system-arm -kernel ./qemu-rpi-kernel/kernel-qemu-4.1.13-jessie \
    -cpu arm1176 -m 256 -M versatilepb \
    -append "root=/dev/sda2 panic=1 rootfstype=ext4 rw console=tty0
console=/dev/ttyAMA3,115200" \
    -hda image.qcow2 -serial stdio -monitor none

This comes up with a working NAT network interface.  I want to modify
the network configuration.  I've tried adding `-netdev
tap,helper=...,id=hn0 -device virtio-net-pci,netdev=hn0,id=nic1` to
the command-line, and it boots but there is no ethernet adapter.

I think I've tried pretty well every network device listed by `-device
?` now and they all fall into two categories: either the required bus
isn't present in the machine (usb and virtio-bus) or as above, they
boot with no ethernet adapter.

I think I could probably get some of the PCI adapters working by
sorting out the appropriate kernel modules in the guest, but before I
do that, it seem to me that whatever the default adapter is should
work - but I can't figure out what it is.  The guest uses the `smc91x`
driver for it, but `-device ?` doesn't list any smc91x network
adapters (it does list a smc91c111 under 'Uncategorized devices', but
trying to use it results in:

qemu-system-arm: Option '-device smc91c111' cannot be handled by this machine

Can anyone suggest how to move this forward?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]