[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: qemu 6.1.0 - i386 <= 2GB?

From: Frans de Boer
Subject: Re: qemu 6.1.0 - i386 <= 2GB?
Date: Tue, 23 Nov 2021 14:33:21 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.3.0

On 23/11/2021 11:44, Narcis Garcia wrote:
El 23/11/21 a les 10:03, Frans de Boer ha escrit:
On 23/11/2021 09:27, Narcis Garcia wrote:
Some 32-bit system can't handle more than 512 MiB of RAM, and some 32-bit systems can handle up to 64 GiB.

This is not related to memory assigned by Qemu to VE.

Narcis Garcia

El 22/11/21 a les 18:38, Frans de Boer ha escrit:

OK, 32-bit systems can't handle more than 4GB memory. So, I specify '-m 4096' and still get only 2GB. Is this (very) old bug still not resolved or is it a feature now?

Regards, Frans.
In theory an 32-bit processor can handle up-to 4GB of physical memory. However, due to limitations of some chip sets, the maximum amount of memory was often 512 MB or 1 GB. At that time the chip sets where lagging behind the processor capabilities.
With newer chip sets it became practically possible to address 4 GB and when using PAE, even beyond that. Although in case of the latter, the address space for a single process was always limited to 4 GB.

So, whatever way you see it, the 2 GB limit imposed by QEMU seems rather arbitrary.

--- Frans.

Before talking about 64 GiB limit, I just tried ubuntu-mate-18.04.1-desktop-i386 in a Qemu 5.2.0 VM
50 GiB assigned and guest OS detects and uses it.

Then, what type of CPU did you specify?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]