[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] qemu-system-ppc broken

From: Alexander Graf
Subject: Re: [Qemu-ppc] qemu-system-ppc broken
Date: Mon, 05 Mar 2012 19:33:53 +0100
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110221 SUSE/3.1.8 Thunderbird/3.1.8

On 03/04/2012 04:34 AM, Laurent Vivier wrote:
When I run:

./ppc-softmmu/qemu-system-ppc -serial mon:stdio

It hangs on a black wi(n)dow (no openbios prompt) with this on serial

OpenBIOS 1.0 [Sep 28 2011 20:46]
Configuration device id QEMU version 1 machine id 2
CPUs: 1
Memory: 128M
UUID: 00000000-0000-0000-0000-000000000000
CPU type PowerPC,750
I can have a prompt if I disable graphic (with "-nographic"), but If I
boot a kernel (with "-cdrom /ISO/debian-500-powerpc-netinst.iso -boot
d"), it hangs at the kernel start:

Please wait, loading kernel...
    Elf32 kernel loaded...
Loading ramdisk...
ramdisk loaded at 01a00000, size: 4321 Kbytes
OF stdout device is: 
command line: console=ttyS0,9600 console=tty0
memory layout at init:
   alloc_bottom : 01e39000
   alloc_top    : 08000000
   alloc_top_hi : 08000000
   rmo_top      : 08000000
   ram_top      : 08000000
Looking for displays
found display   : /address@hidden/QEMU,address@hidden, opening ... done
copying OF device tree ...
Building dt strings...
Building dt structure...
Device tree strings 0x0223a000 ->  0x0223a4f7
Device tree struct  0x0223b000 ->  0x0223d000
Calling quiesce ...
returning from prom_init

Bisect gives me the faulty commit:

de58ac72b6a062d1a61478284c0c0f8a0428613e is the first bad commit
commit de58ac72b6a062d1a61478284c0c0f8a0428613e
Author: Avi Kivity<address@hidden>
Date:   Sun Jan 8 19:46:17 2012 +0200

     ioport: change portio_list not to use memory_region_set_offset()

     memory_region_set_offset() will be going away soon, so don't use it.
     Use an alias instead.

     Signed-off-by: Avi Kivity<address@hidden>
     Reviewed-by: Richard Henderson<address@hidden>

:100644 100644 36fa3a477ebde72de4745bf4e13ad5146f4686fd 
8a474d34928a2e1a6109afd422364f0a983ca0d2 M      ioport.c
:100644 100644 ae3e9da0b5487e68a16f28c459889496160e8e16 
ab29c89fb3ac6bbe72b2b622172cb9ef7c462e62 M      ioport.h

This seems to be the same issue that Mark was facing. Avi fixed it today and sent out a patch :).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]