[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] [Qemu-devel] [PATCH 1/4] PPC: e500: rename mpc8544ds into

From: Paolo Bonzini
Subject: Re: [Qemu-ppc] [Qemu-devel] [PATCH 1/4] PPC: e500: rename mpc8544ds into generic file
Date: Tue, 03 Jul 2012 13:33:29 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120605 Thunderbird/13.0

Il 02/07/2012 23:17, Alexander Graf ha scritto:
>>> No, plain "e500.o" won't work no matter where you put it in the
>>> makefile (unless you add more global prefix setting).  I think
>>> he's suggesting that the plan is to eventually migrate to
>>> everything specifying its full path, though I don't see why.
> Why wouldn't "e500.o" in hw/ppc/Makefile.objs work? I'd hope we
> traverse the target specific path first, no?

Not sure about the question... the idea is to abolish vpath and rely
only on the path to the current Makefile.objs file.

So, e500.o in hw/ppc/Makefile.objs, after the addsuffix would compile to

e500.o in hw/ppc/Makefile.objs, before the addsuffix would compile to
hw/ppc/../e500.o aka hw/e500.o

e500.o in hw/Makefile.objs would compile to hw/e500.o

There is no conflict between hw/e500.o and hw/ppc/e500.o, but of course
if you specify hw/e500.o twice (one normally, one via hw/ppc/..) you get
duplicate definitions.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]