[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] [Qemu-devel] [PATCH 08/13] pseries: Update SLOF for NVRAM

From: Alexander Graf
Subject: Re: [Qemu-ppc] [Qemu-devel] [PATCH 08/13] pseries: Update SLOF for NVRAM support
Date: Wed, 5 Dec 2012 15:35:24 +0100

On 05.12.2012, at 15:09, Erlon Cruz wrote:

Hi Alex,
Could you please post

  * the exact command line you were using

 ./ppc64-softmmu/qemu-system-ppc64 -machine type=pseries,usb=off -m 512 -net nic,vlan=0 -net tap -nographic -cdrom /exports/isos/SLES-11-SP2-DVD-ppc64-GM-DVD1.iso -hda /exports/sles11_sp2.qcow2 -monitor unix:/dev/tty1,nowait,server

Ah, so you're using -M mac99, which means any patch that says "pseries" shouldn't affect that VM at all.

  * details about your host: architecture, OS, kernel version

 Intel(R) Core(TM) i5-2520M CPU @ 2.50GH
 Linux tpad 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

  * is this using KVM or TCG?

  * what SLES exactly are you using here?

SLES-11-SP2-DVD-ppc64-GM-DVD1.iso: sha256 -> 2247dd6bb495eb50860668e46f7d6ba004eece9909f347c8ce487fd6a5f65ee1

  * the exact QEMU version

Git: 01bbd8b... Update version for 1.3.0-rc2

I also run the media check from the installer and it says its OK. The only abnormal think i could see is a message about the network interface, but it doesn't seen to affect the behavior in the rootfs guests:

 Starting udev... ibmveth 1001: (unregistered net_device): unable to change checksum offload settings. 1 rc=-2 ret_attr=1001

This last time I run, before that first error I mentioned I got this error in this package:

Installation of package ./suse/ppc64/liborc-0_4-0-0.4.11-7.5.23.ppc64.rpm failed.
Subprocess failed. Error: RPM failed: Inconsistency detected by ld.so: dl-lookup

but after retrying it passed. But when it hit the vi-base it stuck in that error no matter how many times I retry or skip the package.

This smells quite a lot like a TCG emulation bug. Could you please check if older versions used to work, so whether this is a regression or something that never really worked?

Please also give -M pseries -vga std a try.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]