[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] returning 0x00000000 from prom_init

From: Mark Cave-Ayland
Subject: Re: [Qemu-ppc] returning 0x00000000 from prom_init
Date: Mon, 09 Sep 2013 14:25:49 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.12) Gecko/20130116 Icedove/10.0.12

On 04/09/13 11:01, Doru wrote:

I am trying to boot a 2.6.10(this version specific) kernel image in a
ppc emulated with qemu-system-ppc.
all i get in return is:
address@hidden:~/temp_sys/kern_img$ qemu-system-ppc -kernel
"vmlinux" -hda disk.img -append "console=ttyS0 root=/dev/hda" -nographic -s

 >> =============================================================
 >> OpenBIOS 1.1 [Jul 30 2013 21:44]
 >> Configuration device id QEMU version 1 machine id 2
 >> CPUs: 1
 >> Memory: 128M
 >> UUID: 00000000-0000-0000-0000-000000000000
 >> CPU type PowerPC,750
Welcome to OpenBIOS v1.1 built on Jul 30 2013 21:44
 >> [ppc] Kernel already loaded (0x01000000 + 0x00308b3c) (initrd
0x00000000 + 0x00000000)
 >> [ppc] Kernel command line: console=ttyS0 root=/dev/hda
opening display /address@hidden/QEMU,address@hidden ok
copying OF device tree...done
Initializing fake screen: QEMU,VGA
Calling quiesce ...
returning 0x00000000 from prom_init

I have tried with hda, without hda, with graphic / no graphic, console
tty0,. ttyS0, ttyPZ0, novideo, framebuffer video, and pretty much all i
found on the web regarding this error.
I don't know where to go next from here, i must be doing something wrong.

The process i usually do is:
make menuconfig
(ARCH, CROSS_COMPILE and PATH are set to match my cross_compiler)
I use generic PPC cpu / platform.
My env is xubuntu 12.04.
I am using a 3.4.3 gcc compiler(again i need to use this specific version)
i have tried to use the kernel image with a ppc filesystem, but no use.
I pretty much out of options at the time of writing this.
Any advice ?

Rob Landley has a complete set of minimal build environments (along with startup scripts for QEMU) which can be downloaded from http://landley.net/aboriginal/. I'd suggest looking at the PPC images and using them as a starting point to determine why your particular setup doesn't work.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]