qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] [RFC PATCH v0 2/6] spapr: CPU core device


From: Bharata B Rao
Subject: Re: [Qemu-ppc] [RFC PATCH v0 2/6] spapr: CPU core device
Date: Mon, 29 Feb 2016 11:09:57 +0530
User-agent: Mutt/1.5.23 (2014-03-12)

On Fri, Feb 26, 2016 at 11:46:19AM +0100, Thomas Huth wrote:
> On 25.02.2016 17:22, Bharata B Rao wrote:
> > Add sPAPR specific CPU core device that is based on generic CPU core device.
> > Creating this core device will result in creation of all the CPU thread
> > devices that are part of this core.
> > 
> > Signed-off-by: Bharata B Rao <address@hidden>
> > ---
> ...
> > diff --git a/hw/ppc/spapr_cpu_core.c b/hw/ppc/spapr_cpu_core.c
> > new file mode 100644
> > index 0000000..c44eb61
> > --- /dev/null
> > +++ b/hw/ppc/spapr_cpu_core.c
> > @@ -0,0 +1,210 @@
> > +/*
> > + * sPAPR CPU core device, acts as container of CPU thread devices.
> > + *
> > + * Copyright (C) 2016 Bharata B Rao <address@hidden>
> > + *
> > + * This work is licensed under the terms of the GNU GPL, version 2 or 
> > later.
> > + * See the COPYING file in the top-level directory.
> > + */
> > +#include "hw/cpu/core.h"
> > +#include "hw/ppc/spapr_cpu_core.h"
> > +#include "hw/ppc/spapr.h"
> > +#include "hw/boards.h"
> > +#include "qemu/error-report.h"
> > +#include "qapi/visitor.h"
> > +#include <sysemu/cpus.h>
> > +
> > +static int spapr_cpu_core_realize_child(Object *child, void *opaque)
> > +{
> > +    Error **errp = opaque;
> > +
> > +    object_property_set_bool(child, true, "realized", errp);
> > +    if (*errp) {
> > +        return 1;
> > +    }
> > +    return 0;
> > +}
> > +
> > +static void spapr_cpu_core_realize(DeviceState *dev, Error **errp)
> > +{
> > +    sPAPRCPUCore *core = SPAPR_CPU_CORE(OBJECT(dev));
> > +    sPAPRMachineState *spapr = SPAPR_MACHINE(qdev_get_machine());
> > +    Error *local_err = NULL;
> > +
> > +    if (!core->nr_threads) {
> > +        error_setg(errp, "nr_threads property can't be 0");
> > +        return;
> > +    }
> > +
> > +    if (!core->cpu_model) {
> > +        error_setg(errp, "cpu_model property isn't set");
> > +        return;
> > +    }
> > +
> > +    /*
> > +     * TODO: If slot isn't specified, plug this core into
> > +     * an existing empty slot.
> > +     */
> > +    if (!core->slot) {
> > +        error_setg(errp, "slot property isn't set");
> > +        return;
> > +    }
> > +
> > +    object_property_set_link(OBJECT(spapr), OBJECT(core), core->slot,
> > +                             &local_err);
> > +    if (local_err) {
> > +        error_propagate(errp, local_err);
> > +        return;
> > +    }
> > +
> > +    object_child_foreach(OBJECT(dev), spapr_cpu_core_realize_child, errp);
> > +}
> > +
> > +/*
> > + * This creates the CPU threads for a given @core.
> > + *
> > + * In order to create the threads, we need two inputs - number of
> > + * threads and the cpu_model. These are set as core object's properties.
> > + * When both of them become available/set, this routine will be called from
> > + * either property's set handler to create the threads.
> > + *
> > + * TODO: Dependence of threads creation on two properties is resulting
> > + * in this not-so-clean way of creating threads from either of the
> > + * property setters based on the order in which they get set. Check if
> > + * this can be handled in a better manner.
> > + */
> > +static void spapr_cpu_core_create_threads(sPAPRCPUCore *core, Error **errp)
> > +{
> > +    int i;
> > +
> > +    for (i = 0; i < core->nr_threads; i++) {
> > +        char id[32];
> > +        char type[32];
> > +
> > +        snprintf(type, sizeof(type), "%s-%s", core->cpu_model,
> > +                 TYPE_POWERPC_CPU);
> > +        object_initialize(&core->threads[i], sizeof(core->threads[i]), 
> > type);
> > +
> > +        snprintf(id, sizeof(id), "thread[%d]", i);
> > +        object_property_add_child(OBJECT(core), id, 
> > OBJECT(&core->threads[i]),
> > +                                  errp);
> 
> Need to check errp here to see whether something went wrong?

Yes, I will use local_err and them propagate.

> 
> > +    }
> > +}
> > +
> > +static char *spapr_cpu_core_prop_get_slot(Object *obj, Error **errp)
> > +{
> > +    sPAPRCPUCore *core = SPAPR_CPU_CORE(obj);
> > +
> > +    return core->slot;
> > +}
> > +
> > +static void spapr_cpu_core_prop_set_slot(Object *obj, const char *val,
> > +                                              Error **errp)
> > +{
> > +    sPAPRCPUCore *core = SPAPR_CPU_CORE(obj);
> > +
> > +    core->slot = g_strdup(val);
> > +}
> > +
> > +static char *spapr_cpu_core_prop_get_cpu_model(Object *obj, Error **errp)
> > +{
> > +    sPAPRCPUCore *core = SPAPR_CPU_CORE(obj);
> > +
> > +    return core->cpu_model;
> > +}
> > +
> > +static void spapr_cpu_core_prop_set_cpu_model(Object *obj, const char *val,
> > +                                              Error **errp)
> > +{
> > +    sPAPRCPUCore *core = SPAPR_CPU_CORE(obj);
> > +    MachineState *machine = MACHINE(qdev_get_machine());
> > +
> > +    /*
> > +     * cpu_model can't be different from what is specified with -cpu
> > +     */
> > +    if (strcmp(val, machine->cpu_model)) {
> > +       error_setg(errp, "cpu_model should be %s", machine->cpu_model);
> 
> s/should/must/

sure :)

> 
> > +       return;
> > +    }
> > +
> > +    core->cpu_model = g_strdup(val);
> > +    if (core->nr_threads && core->cpu_model) {
> > +        spapr_cpu_core_create_threads(core, errp);
> > +    }
> > +}
> > +
> > +static void spapr_cpu_core_prop_get_nr_threads(Object *obj, Visitor *v,
> > +                                               const char *name, void 
> > *opaque,
> > +                                               Error **errp)
> > +{
> > +    sPAPRCPUCore *core = SPAPR_CPU_CORE(obj);
> > +    int64_t value = core->nr_threads;
> > +
> > +    visit_type_int(v, name, &value, errp);
> > +}
> > +
> > +static void spapr_cpu_core_prop_set_nr_threads(Object *obj, Visitor *v,
> > +                                               const char *name, void 
> > *opaque,
> > +                                               Error **errp)
> > +{
> > +    sPAPRCPUCore *core = SPAPR_CPU_CORE(obj);
> > +    Error *local_err = NULL;
> > +    int64_t value;
> > +
> > +    visit_type_int(v, name, &value, &local_err);
> > +    if (local_err) {
> > +        error_propagate(errp, local_err);
> > +        return;
> > +    }
> > +
> > +    /* Allow only homogeneous configuration */
> > +    if (value != smp_threads) {
> > +        error_setg(errp, "nr_threads should be %d", smp_threads);
> 
> s/should/must/
> 
> > +        return;
> > +    }
> > +
> > +    core->nr_threads = value;
> > +    core->threads = g_malloc0(core->nr_threads * sizeof(PowerPCCPU));
> 
> I think it's preferable to use g_new0 for such allocations instead.

Ok.

> 
> Also, should this memory maybe be freed during instance_finalize again,
> so that there is no memory leak here in case the cores are deleted again
> one day?

I will be forced to care of this when I add hot removal in the next version.

> 
> > +    if (core->nr_threads && core->cpu_model) {
> > +        spapr_cpu_core_create_threads(core, errp);
> > +    }
> > +}
> > +
> > +static void spapr_cpu_core_instance_init(Object *obj)
> > +{
> > +    object_property_add(obj, "nr_threads", "int",
> > +                        spapr_cpu_core_prop_get_nr_threads,
> > +                        spapr_cpu_core_prop_set_nr_threads,
> > +                        NULL, NULL, NULL);
> > +    object_property_add_str(obj, "cpu_model",
> > +                            spapr_cpu_core_prop_get_cpu_model,
> > +                            spapr_cpu_core_prop_set_cpu_model,
> > +                            NULL);
> > +    object_property_add_str(obj, "slot",
> > +                            spapr_cpu_core_prop_get_slot,
> > +                            spapr_cpu_core_prop_set_slot,
> > +                            NULL);
> > +}
> > +
> > +static void spapr_cpu_core_class_init(ObjectClass *oc, void *data)
> > +{
> > +    DeviceClass *dc = DEVICE_CLASS(oc);
> > +
> > +    dc->realize = spapr_cpu_core_realize;
> > +}
> > +
> > +static const TypeInfo spapr_cpu_core_type_info = {
> > +    .name = TYPE_SPAPR_CPU_CORE,
> > +    .parent = TYPE_CPU_CORE,
> > +    .instance_init = spapr_cpu_core_instance_init,
> > +    .instance_size = sizeof(sPAPRCPUCore),
> > +    .class_init = spapr_cpu_core_class_init,
> > +};
> > +
> > +static void spapr_cpu_core_register_types(void)
> > +{
> > +    type_register_static(&spapr_cpu_core_type_info);
> > +}
> > +
> > +type_init(spapr_cpu_core_register_types)
> > diff --git a/include/hw/ppc/spapr_cpu_core.h 
> > b/include/hw/ppc/spapr_cpu_core.h
> > new file mode 100644
> > index 0000000..ed9bc7f
> > --- /dev/null
> > +++ b/include/hw/ppc/spapr_cpu_core.h
> > @@ -0,0 +1,32 @@
> > +/*
> > + * sPAPR CPU core device.
> > + *
> > + * Copyright (C) 2016 Bharata B Rao <address@hidden>
> > + *
> > + * This work is licensed under the terms of the GNU GPL, version 2 or 
> > later.
> > + * See the COPYING file in the top-level directory.
> > + */
> > +#ifndef HW_SPAPR_CPU_CORE_H
> > +#define HW_SPAPR_CPU_CORE_H
> > +
> > +#include "hw/qdev.h"
> > +#include "hw/cpu/core.h"
> > +
> > +#define TYPE_SPAPR_CPU_CORE "spapr-cpu-core"
> > +#define SPAPR_CPU_CORE(obj) \
> > +    OBJECT_CHECK(sPAPRCPUCore, (obj), TYPE_SPAPR_CPU_CORE)
> > +
> > +typedef struct sPAPRCPUCore {
> > +    /*< private >*/
> > +    DeviceState parent_obj;
> > +
> > +    /*< public >*/
> > +    int nr_threads;
> > +    char *cpu_model;
> > +    char *slot;
> 
> <bikeshedpainting>
> I'd maybe call that "slot_name" instead ... if you only call it "slot",
> I'd rather think of an integer value than a string here.
> </bikeshedpainting>

Point taken, pc-dimm has slot which is a number :)

Regards,
Bharata.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]