qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 21/33] spapr, xics, xive: Move cpu_intc_create from SpaprI


From: Cédric Le Goater
Subject: Re: [PATCH v2 21/33] spapr, xics, xive: Move cpu_intc_create from SpaprIrq to SpaprInterruptController
Date: Mon, 30 Sep 2019 07:28:45 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.1.0

On 30/09/2019 03:49, David Gibson wrote:
> On Fri, Sep 27, 2019 at 12:16:49PM +0200, Greg Kurz wrote:
>> On Fri, 27 Sep 2019 15:50:16 +1000
>> David Gibson <address@hidden> wrote:
>>
>>> This method essentially represents code which belongs to the interrupt
>>> controller, but needs to be called on all possible intcs, rather than
>>> just the currently active one.  The "dual" version therefore calls
>>> into the xics and xive versions confusingly.
>>>
>>> Handle this more directly, by making it instead a method on the intc
>>> backend, and always calling it on every backend that exists.
>>>
>>> While we're there, streamline the error reporting a bit.
>>>
>>> Signed-off-by: David Gibson <address@hidden>
> [snip]
>>> @@ -525,6 +469,30 @@ static void spapr_irq_check(SpaprMachineState *spapr, 
>>> Error **errp)
>>>  /*
>>>   * sPAPR IRQ frontend routines for devices
>>>   */
>>> +int spapr_irq_cpu_intc_create(SpaprMachineState *spapr,
>>> +                              PowerPCCPU *cpu, Error **errp)
>>> +{
>>> +    if (spapr->xive) {
>>> +        SpaprInterruptController *intc = SPAPR_INTC(spapr->xive);
>>> +        SpaprInterruptControllerClass *sicc = SPAPR_INTC_GET_CLASS(intc);
>>> +
>>> +        if (sicc->cpu_intc_create(intc, cpu, errp) < 0) {
>>> +            return -1;
>>> +        }
>>> +    }
>>> +
>>> +    if (spapr->ics) {
>>> +        SpaprInterruptController *intc = SPAPR_INTC(spapr->ics);
>>> +        SpaprInterruptControllerClass *sicc = SPAPR_INTC_GET_CLASS(intc);
>>> +
>>> +        if (sicc->cpu_intc_create(intc, cpu, errp) < 0) {
>>> +            return -1;
>>> +        }
>>> +    }
>>> +
>>
>> Instead of these hooks, what about open-coding spapr_xive_cpu_intc_create()
>> and xics_spapr_cpu_intc_create() directly here, like you already did for the
>> ICS and the XIVE objects in spapr_irq_init() ?
> 
> I'd prefer not to.  The idea is I want to treat this as basically:
> 
>       foreach_possible_intc(intc)
>               intc::cpu_intc_create(...)
> 
> If I find time I might indeed replace the explicit ics and xive
> pointers with just an array of SpaprInterruptController *.

Or you could use object_child_foreach() and check for the type. If we had
a helper object_child_foreach_type(), we could use it elsewhere.

 
> init is fundamentally different though, because it needs to *create*
> that list (implicit or explicit) of possible intcs, so it can't be
> based on an existing one.
> 
>>
>>> +    return 0;
>>> +}
>>> +
>>>  void spapr_irq_init(SpaprMachineState *spapr, Error **errp)
>>>  {
>>>      MachineState *machine = MACHINE(spapr);
>>> @@ -763,7 +731,6 @@ SpaprIrq spapr_irq_xics_legacy = {
>>>      .free        = spapr_irq_free_xics,
>>>      .print_info  = spapr_irq_print_info_xics,
>>>      .dt_populate = spapr_dt_xics,
>>> -    .cpu_intc_create = spapr_irq_cpu_intc_create_xics,
>>>      .post_load   = spapr_irq_post_load_xics,
>>>      .reset       = spapr_irq_reset_xics,
>>>      .set_irq     = spapr_irq_set_irq_xics,
>>> diff --git a/include/hw/ppc/spapr_irq.h b/include/hw/ppc/spapr_irq.h
>>> index b9398e0be3..30d660ff1e 100644
>>> --- a/include/hw/ppc/spapr_irq.h
>>> +++ b/include/hw/ppc/spapr_irq.h
>>> @@ -43,8 +43,22 @@ typedef struct SpaprInterruptController 
>>> SpaprInterruptController;
>>>  
>>>  typedef struct SpaprInterruptControllerClass {
>>>      InterfaceClass parent;
>>> +
>>> +    /*
>>> +     * These methods will typically be called on all intcs, active and
>>> +     * inactive
>>> +     */
>>> +    int (*cpu_intc_create)(SpaprInterruptController *intc,
>>> +                            PowerPCCPU *cpu, Error **errp);
>>>  } SpaprInterruptControllerClass;
>>>  
>>> +void spapr_irq_print_info(SpaprMachineState *spapr, Monitor *mon);
>>> +void spapr_irq_dt(SpaprMachineState *spapr, uint32_t nr_servers,
>>> +                  void *fdt, uint32_t phandle);
>>
>> These two ^^ seem to belong to later patches.
>>
>>> +int spapr_irq_cpu_intc_create(SpaprMachineState *spapr,
>>> +                              PowerPCCPU *cpu, Error **errp);
>>> +
>>> +
>>>  void spapr_irq_msi_init(SpaprMachineState *spapr, uint32_t nr_msis);
>>>  int spapr_irq_msi_alloc(SpaprMachineState *spapr, uint32_t num, bool align,
>>>                          Error **errp);
>>> @@ -61,8 +75,6 @@ typedef struct SpaprIrq {
>>>      void (*print_info)(SpaprMachineState *spapr, Monitor *mon);
>>>      void (*dt_populate)(SpaprMachineState *spapr, uint32_t nr_servers,
>>>                          void *fdt, uint32_t phandle);
>>> -    void (*cpu_intc_create)(SpaprMachineState *spapr, PowerPCCPU *cpu,
>>> -                            Error **errp);
>>>      int (*post_load)(SpaprMachineState *spapr, int version_id);
>>>      void (*reset)(SpaprMachineState *spapr, Error **errp);
>>>      void (*set_irq)(void *opaque, int srcno, int val);
>>
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]