[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: qemu-system-ppc 5.0 rc1 crashing on Windows

From: Philippe Mathieu-Daudé
Subject: Re: qemu-system-ppc 5.0 rc1 crashing on Windows
Date: Thu, 2 Apr 2020 12:47:00 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

Cc'ing the persons referenced in the commit you referred,
who happened to be chatting about this issue few hours ago on IRC.

On 4/2/20 11:28 AM, Howard Spoelstra wrote:

I just compiled qemu-system-ppc for Windows, using native msys2 on Windows 10 64 bit and the 64 bit mingw cross compiler on Fedora 31. Both create executables that crash:

qemu-system-ppc.exe -L pc-bios -boot c -m 512 -M mac99,via=pmu -h
da C:\Mac-disks\9.2.img
Exception code=0xc0000005 flags=0x0 at 0x00007FFB2A602078. Access violation - attempting to write data at address 0x00000000034C76EC

I bisected this down to:

d2cd29e30736afd4a1e8cac3cf4da360bbc65978 is the first bad commit
commit d2cd29e30736afd4a1e8cac3cf4da360bbc65978
Author: Richard Henderson <address@hidden <mailto:address@hidden>>
Date:   Tue Dec 17 13:47:37 2019 -1000

     configure: Do not force pie=no for non-x86

     PIE is supported on many other hosts besides x86.

     The default for non-x86 is now the same as x86: pie is used
     if supported, and may be forced via --enable/--disable-pie.

     The original commit (40d6444e91c) said:

       "Non-x86 are not changed, as they require TCG changes"

     but I think that's wrong -- there's nothing about PIE that
     affects TCG one way or another.

     Tested on aarch64 (bionic) and ppc64le (centos 7) hosts.

    Tested-by: Alex Bennée <address@hidden <mailto:address@hidden>>     Reviewed-by: Alex Bennée <address@hidden <mailto:address@hidden>>     Reviewed-by: Philippe Mathieu-Daudé <address@hidden <mailto:address@hidden>>     Signed-off-by: Richard Henderson <address@hidden <mailto:address@hidden>>

Please note that I tried again after applying patch https://patchwork.ozlabs.org/patch/1265368/ However, this has not solved my issue.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]