[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: qemu-system-ppc 5.0 rc1 crashing on Windows

From: Howard Spoelstra
Subject: Re: qemu-system-ppc 5.0 rc1 crashing on Windows
Date: Thu, 2 Apr 2020 19:15:10 +0200

On Thu, Apr 2, 2020 at 4:58 PM Alex Bennée <address@hidden> wrote:

Howard Spoelstra <address@hidden> writes:

> On Thu, Apr 2, 2020 at 3:20 PM Alex Bennée <address@hidden> wrote:
>> Howard Spoelstra <address@hidden> writes:
>> > On Thu, Apr 2, 2020 at 12:47 PM Philippe Mathieu-Daudé <
>> address@hidden>
>> > wrote:
>> >
>> >> Cc'ing the persons referenced in the commit you referred,
>> >> who happened to be chatting about this issue few hours ago on IRC.
>> >>
>> >>
>> > Thanks, adding --disable-pie to configure solves this issue, but I guess
>> > the default detection should work ;-)
>> Could you try the following patch:
>>   Subject: [PATCH for-5.0] configure: Add -Werror to PIE probe
>>   Date: Wed,  1 Apr 2020 14:47:56 -0700
>>   Message-Id: <address@hidden>
>> which fixed the win mxe cross compile failures.
> Hi,
> Thanks for your reply. However, I already did that. Please see the end of
> my original message repeated below.
> I never experienced compilation errors, just a crash when running.
>>> > Please note that I tried again after applying patch
>>> > https://patchwork.ozlabs.org/patch/1265368/ However, this has not
>>> solved
>>> > my issue.

Ahh sorry missed that. Is there anyway you get can a back trace?

Alex Bennée


I might need a bit of help here.
I compiled qemu with:
./configure --cross-prefix=x86_64-w64-mingw32- --target-list=ppc-softmmu --enable-gtk --enable-sdl --enable-debug

Then run gdb for Windows:

C:\qemu-debugging>gdb --args c:\qemu-master-msys2\qemu-system-ppc.exe -L c:\qemu-master-msys2\pc-bios -boot c -m 256 -M mac99,via=pmu -hda c:\Mac-disks\9.2.img
GNU gdb (GDB)
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-w64-mingw32".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word".

This binary was built by Equation Solution <http://www.Equation.com>...
Reading symbols from c:\qemu-master-msys2\qemu-system-ppc.exe...done.
(gdb) run
Starting program: c:\qemu-master-msys2\qemu-system-ppc.exe -L c:\qemu-master-msys2\pc-bios -boot c -m 256 -M "mac99,via=pmu" -hda c:\Mac-disks\9.2.img
[New Thread 3076.0x1384]
[New Thread 3076.0x9a0]
[New Thread 3076.0x3074]
[New Thread 3076.0x3014]
[Thread 3076.0x9a0 exited with code 0]
[Thread 3076.0x3014 exited with code 0]
[Thread 3076.0x3074 exited with code 0]
[Inferior 1 (process 3076) exited with code 035610000]
(gdb) thread apply all bt full

I get no output.

(gdb) bt
No stack.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]