[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: e6500 stvx instruction

From: Fabiano Rosas
Subject: Re: e6500 stvx instruction
Date: Wed, 07 Jul 2021 11:20:49 -0300

BALATON Zoltan <balaton@eik.bme.hu> writes:

> Hello,
> On Sun, 4 Jul 2021, mario@locati.it wrote:
>> I tested QEMU 6.0 on a real e6500 with KVM enabled and it fails.
>> Not just that, it enter and infinite loop of kernel errors that completely 
>> hang the system so I have to hardware reset.
>> At the following address you may find the serial output from my NXP T2080RDB
>> https://repo.powerprogress.org/t2080rdb/serial_output_real_e6500_NXP_T2080RDB_qemu_kvm.txt
>> I included in the serial output the compilation of QEMU 6.0 so you may check 
>> what was enabled.
>> I run QEMU using the following command
>> sudo qemu-system-ppc64 -enable-kvm -M ppce500 -cpu e6500 \
>> -m 1G -vga none -nographic -kernel book3e_e6500_kernel_5.12.10 \
>> -append "root=/dev/vda1 rw" -drive \
>> format=qcow2,file=hdd_debian_sid_ppc64_basic.qcow2,index=0,if=virtio
>> The kernels, QCOW2 HDD image are all available from
>> https://repo.powerprogress.org/t2080rdb/
> Please cut non-relevant old mails when replying and refrain from top 
> posting if possible. That way it's more readable and clearer what's 
> relevant.
> I'm afraid I can't help because I don't know anything about PPC KVM. But 
> I'm not that surprised it's not working becuase PPC Linux is not much used 
> these days and what activity is there is mainly for PPC64LE on server 
> CPUs. Probably it was a long time ago anybody tried BookE PPC so it could 
> be it has bitrotten if it ever worked for e6500. I'm surprised it's 
> working at all because I thought BookE KVM was dropped from latest 
> kernels. It's not clear to me what the warnings you got mean, maybe look 
> in system logs if there are more details there and ask on the appropriate 
> Linux list. I'm not sure which is that but this looks like it might be the 
> place: http://vger.kernel.org/vger-lists.html#kvm-ppc


just to confirm that this is indeed a KVM bug, it doesn't seem related
to the issues we have been discussing on e6500 on TCG so far.

Looking at the code it seems that we are hitting a WARN about preemption
being enabled when it shouldn't. If I understand it correctly it would
just be a matter of moving some code that enables interrupts
around. Something like:

else {
        /* interrupts now hard-disabled */
-       kvmppc_fix_ee_before_entry();
+       kvmppc_fix_ee_before_entry();

I'll start a thread in the KVM list to discuss this. I'll put you all on

> Regards,
> BALATON Zoltan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]