[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 2/9] target/ppc: add errp to kvmppc_read_int_cpu_dt()

From: Mark Cave-Ayland
Subject: Re: [PATCH 2/9] target/ppc: add errp to kvmppc_read_int_cpu_dt()
Date: Wed, 13 Jul 2022 21:30:21 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.10.0

On 12/07/2022 15:54, BALATON Zoltan wrote:

On Tue, 12 Jul 2022, Mark Cave-Ayland wrote:
On 11/07/2022 08:42, Cédric Le Goater wrote:
Anything special I should know ?

As I don't have access to a G5 I've never tried that, however the qemu-system-ppc64 mac99 is wired differently to the qemu-system-ppc mac99 machine so I wouldn't be surprised if something is broken there.

My normal test for MacOS is something like:

    qemu-system-ppc -M mac99 -accel kvm -hda macos104.img

Can you try qemu-system-ppc and see if it is any better? If not then I can fire up the G4 and get the git hashes for my last known working configuration.

Same issue with 32bit.

I've just fired up my G4 to test this again, pulled the latest QEMU git master and confirmed that I have a working setup with the details below:

Host kernel: (5.1.0-rc2+)
commit a3ac7917b73070010c05b4485b8582a6c9cd69b6
Author: Linus Torvalds <torvalds@linux-foundation.org>
Date:   Mon Mar 25 14:49:00 2019 -0700

Guest kernel: (4.14.0-3-powerpc)
using Debian ports debian-9.0-powerpc-NETINST-1.iso

Command line:
./qemu-system-ppc [-M mac99] -accel kvm -cdrom /home/mca/images/debian-9.0-powerpc-NETINST-1.iso -boot d -nographic

However if I switch to using the latest Debian ports debian-10.0.0-powerpc-NETINST-1.iso then I get a failure:

[    0.198565] BUG: Unable to handle kernel data access on read at 0xbb0030d4

What is or should be at this address and why does the kernel access it? By default I see nothing mapped there. Do you need more RAM? Maybe the default 128 MB is not enough for newer kernels? I've seen such problem with other OSes before.

Yeah I've already tried increasing the RAM and it makes no difference. It wouldn't surprise me if it's a kernel issue since Christophe has done a lot of low-level work for 32-bit PPC including moving routines from asm to C and KASAN. I'm away for a few days but I will do a bisect when I get back, unless anyone beats me to it...



reply via email to

[Prev in Thread] Current Thread [Next in Thread]