[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: QEMU latest release riscv32-softmmu not working

From: arman avetisyan
Subject: Re: QEMU latest release riscv32-softmmu not working
Date: Fri, 14 Aug 2020 13:03:39 +0400

Hi QEMU Team

-bios none worked. It fixed the issue.
Thank you!

Thanks, Arman

On Fri, Aug 14, 2020 at 12:45 PM Chih-Min Chao <chihmin.chao@sifive.com> wrote:

On Fri, Aug 14, 2020 at 3:31 PM Philippe Mathieu-Daudé <f4bug@amsat.org> wrote:
Hi Arman,

On 8/13/20 10:20 PM, arman avetisyan wrote:
> Hi QEMU Team, having issue running riscv32-softmmu

Cc'ing this to the QEMU RISCV mailing list.

> After running riscv32-softmmu supplying custom linux build it crashes
> and complains about rom segments overlaping
> $ qemu-system-riscv32 -nographic -machine virt -kernel bbl   -append
> "root=/dev/vda ro console=ttyS0"   -drive
> file=busybear.bin,format=raw,id=hd0   -device virtio-blk-device,drive=hd0
> Log:
> rom: requested regions overlap (rom phdr #0: bbl.
> free=0x000000008000c160, addr=0x0000000080000000)
> qemu-system-riscv32: rom check and register reset failed
Try to add "-bios none"

Chih-Min Chao 
> qemu version = 5.1.0
> Pulled from github.com <http://github.com> (latest commit in master =
> also tagged v5.1.0)
> Same files are used in 4.2.0 and are working fine.
> Tried different kernel files, all had same issue.
> How can I help to debug it? I really want to modify QEMU to support new
> board/machine but having hard time building latest version from github
> (which happens to be release v5.1.0)
> Thanks, Arman

reply via email to

[Prev in Thread] Current Thread [Next in Thread]