[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v2 1/7] target: rename all *_do_interupt functions to _do_int
Re: [PATCH v2 1/7] target: rename all *_do_interupt functions to _do_interrupt_locked
Mon, 31 Aug 2020 14:14:21 -0700
Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0
On 8/19/20 11:28 AM, Robert Foley wrote:
> The rename of all *_do_interrupt functions to *_do_interrupt_locked
> is preparation for pushing the BQL lock around these functions
> down into the per-arch implementation of *_do_interrupt.
> In a later patch which pushes down the lock, we will add
> a new *_do_interrupt function which grabs the BQL and calls to
> This is the first patch in a series of transitions to move the
> BQL down into the do_interrupt per arch function. This set of
> transitions is needed to maintain bisectability.
> The purpose of this set of changes is to set the groundwork
> so that an arch could move towards removing
> the BQL from the cpu_handle_interrupt/exception paths.
> This approach was suggested by Paolo Bonzini.
> For reference, here are key posts in the discussion, explaining
> the reasoning/benefits of this approach.
> Signed-off-by: Robert Foley <email@example.com>
Reviewed-by: Richard Henderson <firstname.lastname@example.org>