[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 17/22] tests/bench: Rename test_akcipher_keys.inc -> test_akcipher
From: |
Michael Tokarev |
Subject: |
[PULL 17/22] tests/bench: Rename test_akcipher_keys.inc -> test_akcipher_keys.c.inc |
Date: |
Fri, 20 Sep 2024 10:41:29 +0300 |
From: Philippe Mathieu-Daudé <philmd@linaro.org>
Since commit 139c1837db ("meson: rename included C source files
to .c.inc"), QEMU standard procedure for included C files is to
use *.c.inc.
Besides, since commit 6a0057aa22 ("docs/devel: make a statement
about includes") this is documented in the Coding Style:
If you do use template header files they should be named with
the ``.c.inc`` or ``.h.inc`` suffix to make it clear they are
being included for expansion.
Rename "test_akcipher_keys.inc" as "test_akcipher_keys.c.inc".
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Signed-off-by: Michael Tokarev <mjt@tls.msk.ru>
---
tests/bench/benchmark-crypto-akcipher.c | 2 +-
.../bench/{test_akcipher_keys.inc => test_akcipher_keys.c.inc} | 0
2 files changed, 1 insertion(+), 1 deletion(-)
rename tests/bench/{test_akcipher_keys.inc => test_akcipher_keys.c.inc} (100%)
diff --git a/tests/bench/benchmark-crypto-akcipher.c
b/tests/bench/benchmark-crypto-akcipher.c
index 750c7e89ee..0a6e5db1d6 100644
--- a/tests/bench/benchmark-crypto-akcipher.c
+++ b/tests/bench/benchmark-crypto-akcipher.c
@@ -16,7 +16,7 @@
#include "crypto/akcipher.h"
#include "standard-headers/linux/virtio_crypto.h"
-#include "test_akcipher_keys.inc"
+#include "test_akcipher_keys.c.inc"
static QCryptoAkCipher *create_rsa_akcipher(const uint8_t *priv_key,
size_t keylen,
diff --git a/tests/bench/test_akcipher_keys.inc
b/tests/bench/test_akcipher_keys.c.inc
similarity index 100%
rename from tests/bench/test_akcipher_keys.inc
rename to tests/bench/test_akcipher_keys.c.inc
--
2.39.5
- [PULL 07/22] tests/unit: Really build pbkdf test on macOS, (continued)
- [PULL 07/22] tests/unit: Really build pbkdf test on macOS, Michael Tokarev, 2024/09/20
- [PULL 08/22] hw/virtio/Kconfig: Include vhost-user-scmi only on arm targets, Michael Tokarev, 2024/09/20
- [PULL 09/22] hw/display: Fix mirrored output in dm163, Michael Tokarev, 2024/09/20
- [PULL 10/22] envlist: Remove unused envlist_parse, Michael Tokarev, 2024/09/20
- [PULL 11/22] hw/sysbus: Remove unused sysbus_mmio_unmap, Michael Tokarev, 2024/09/20
- [PULL 13/22] tests/qemu-iotests/testenv: Use the "virt" machine for or1k, Michael Tokarev, 2024/09/20
- [PULL 12/22] util/cutils: Remove unused qemu_get_exec_dir, Michael Tokarev, 2024/09/20
- [PULL 14/22] tests/qemu-iotests/testenv: Use the "r2d" machine for sh4/sh4eb, Michael Tokarev, 2024/09/20
- [PULL 15/22] tests/functional: Put the or1k_sim test into the slow category, Michael Tokarev, 2024/09/20
- [PULL 16/22] target/hexagon: Rename macros.inc -> macros.h.inc, Michael Tokarev, 2024/09/20
- [PULL 17/22] tests/bench: Rename test_akcipher_keys.inc -> test_akcipher_keys.c.inc,
Michael Tokarev <=
- [PULL 18/22] tests/functional: Correct typo in test_netdev_ethtool.py SPDX tag, Michael Tokarev, 2024/09/20
- [PULL 19/22] license: Simplify GPL-2.0-or-later license descriptions, Michael Tokarev, 2024/09/20
- [PULL 21/22] license: Update deprecated SPDX tag GPL-2.0+ to GPL-2.0-or-later, Michael Tokarev, 2024/09/20
- [PULL 20/22] license: Update deprecated SPDX tag LGPL-2.0+ to LGPL-2.0-or-later, Michael Tokarev, 2024/09/20
- [PULL 22/22] license: Update deprecated SPDX tag GPL-2.0 to GPL-2.0-only, Michael Tokarev, 2024/09/20
- Re: [PULL 00/22] Trivial patches for 2024-09-20, Peter Maydell, 2024/09/26