[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

hints and problems with 0.5.5 .deb package

From: boud
Subject: hints and problems with 0.5.5 .deb package
Date: Sun, 28 Aug 2005 20:35:50 +0200 (CEST)

hi samizdat developers,

i've tried installing samizdat-0.5.5 from the debian package on a
sarge installation with apache-1.3.33-3 and postgresql
7.4.7-6sarge1. i partly succeeded, but not totally. Here is some

On Debian GNU/Linux, you can install all that with the following

  apt-get install ruby apache libapache-mod-ruby postgresql libdbd-pg-ruby \
     libyaml-ruby libgettext-ruby1.8 libalgorithm-diff-ruby libredcloth-ruby

i had dependency problems - probably because before doing this apt-get
line, i (unsuccessfully) tried
dpkg -i libtidy-ruby1.8_1.1.2-1_all.deb so apt-get was probably already confused.

- i have apache2, postgresql
- i removed apache postgresql from the above list

i did apt-get -f install
which set up
Setting up libruby1.8 (1.8.2-7) ...
Setting up libtidy0 (20050415-1) ...
Setting up libtidy-ruby1.8 (1.1.2-1) ...

which to me suggests it already had the info about the libtidy-ruby package, which was why it had problems.

 dpkg -i libsamizdat-ruby1.8_0.5.5-1_all.deb
 dpkg -i samizdat_0.5.5-1_all.deb

Fine. No problems.
Samizdat object cache: disabled, see /etc/default/samizdat

 * PostgreSQL Setup
   su - postgres
   createdb samizdat
   createuser samizdat
-> *** What answers are recommended here?
Shall the new user be allowed to create databases? (y/n) y
Shall the new user be allowed to create more new users? (y/n) y

instead of:
   local   samizdat    all                                  ident samizdat
   local   all         all                                  ident sameuser

i'm trying:
local   all         postgres                                    ident sameuser
local   samizdat        all                                     ident samizdat
local   all             angdraug                                ident sameuser

4. for the .deb installation:
   psql samizdat -f database/create.sql
   psql samizdat -f database/triggers.sql

   psql samizdat -f /usr/share/samizdat/database/create.sql
   psql samizdat -f /usr/share/samizdat/database/triggers.sql

If PL/pgSQL is not enabled in the "template1" database of your
PostgreSQL installation, you will have to enable it in "samizdat"
database manually:

   createlang plpgsql samizdat

Maybe add: "If you don't know if it's already enabled, just do this
anyway, it won't hurt."  i'm not a total beginner in postgresql, but
i'm still rather new to it - i didn't figure out how to check whether
or not "PL/pgSQL" is enabled in the template1 database. i'm sure the
answer is easy, but at least to me it wasn't obvious. If i had known
it was safe to do anyway, then i would have just done it and not worried.

If you use different PostgreSQL authentication method for Samizdat,
update Database#new method in samizdat/storage.rb accordingly.

In /usr/lib/ruby/1.8/samizdat/storage.rb i cannot see anything
like "Database#new method" - i don't need it, so maybe it's not needed

[i just started looking at /usr/share/doc/samizdat/install.txt.gz...
aptitude install libtidy0 libdl-ruby
- this runs OK]

Unpack Samizdat into your document root (/var/www on Debian), or
anywhere else you want Samizdat to run from, and enable Ruby scripting
and URL rewriting by putting following lines into .htaccess file in that

The 0.5.5 package still has the above line in
/usr/share/doc/samizdat/install.txt.gz after installing from .deb but in fact the apache installation suggested

seems to only require the config.yaml file to be installed in the
/var/www/samizdat directory or (whatever DOCUMENT_ROOT is).

In the default configuration, Samizdat will confirm email addresses for
new and modified accounts over email, using a sendmail program
configured by the email:sendmail option in the config.yaml. The same

From the .deb package, config.yaml is
and modifying a file outside of the /etc/ hierarchy is rather inconsistent
with debian practice IMHO.

But it seems to me that cp -p /usr/share/samizdat/config.yaml ${DOCUMENT_ROOT}/samizdat/
is enough.  (see point 7.)

i put in the apache config of:
except for a few modifications of DOCUMENT_ROOT  (i use a different
place to /var/www/samizdat)

and i put "/samizdat" at the front of

    AliasMatch ^/samizdat/(foci|history|index|item|login|logout|member|message|\
moderation|pingback|query|resource)\.rb /usr/lib/cgi-bin/samizdat/$1.rb

* same for Alias /css/ i put
Alias /samizdat/css/ ...

9. OK, i get some sort of a front page :))))))))

However, publishing with  message.rb  fails. :(  i get a new interface,
type in some stuff in the boxes, click on preview, and then just get "Sending request to... " messages in my browser but nothing changes
in what i see in the browser (eventually i get a box with "The document
contains no data."), and nothing appears in the apache logs.

My guess is that the problem is something to do with authorisation somewhere, file permissions, sockets, and so on?

Any hints of what i should check?

10. /usr/share/doc/samizdat/install.txt.gz recommends
   ruby test/ts_samizdat.rb
but this is not part of the .deb package

Is it a good idea to try ts_samizdat.rb from 0.5.4 on the 0.5.5 .deb installation?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]