[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-hackers-public] hgweb provides a broken file when trying t

From: Assaf Gordon
Subject: Re: [Savannah-hackers-public] hgweb provides a broken file when trying to download an archive
Date: Wed, 8 Feb 2017 22:31:04 -0500


> On Feb 8, 2017, at 15:13, Bob Proulx <address@hidden> wrote:
>> in the following Bug report someone tried to download a specific octave
>> revision from the hgweb interface, but got a corrupted file(files in the
>> archive were missing).
>> [...]

This bug was closed - somewhat confusing...
I guess it was closed because the OP found an alternative download link,
not because this was solved?

> Reading the bug ticket I agree this looks like aproblem with the hg
> web interface.


> will need to debug it.  This
> is an upgrade of the hg web interface from the old to the new.  We
> will need to understand it and debug it.  None of us are hg experts.

Few more observations:

These consistently fail (truncated file):

While this consistently succeeds:

Looking at the running processes, it seems archiving is
done internally by mercurial's 'hgwebdir' module
( "from mercurial.hgweb.hgwebdir_mod import hgwebdir" in our script ).
It does not fork and does not run tar/gzip/bzip2 .

A cursory google-search did not come up with anything about hgwebdir
truncating archives, but I'll continue to look.

comments welcome,
 - assaf

reply via email to

[Prev in Thread] Current Thread [Next in Thread]