[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-hackers] Re: bug in Anon CVS how to

From: Jaime E. Villate
Subject: Re: [Savannah-hackers] Re: bug in Anon CVS how to
Date: Fri, 20 Sep 2002 08:45:45 +0100
User-agent: Mutt/1.2.5i

Hi Robert,
Thank you very much for your feedback which is very useful. Most of us were
already familiar with CVS and SourceForge before we started using Savannah, so
we are not aware of the difficulties that other users face when they start
using Savannah.

Savannah was initially running the SourceForge code, which was supposed to be
very good and easy to use, being developed by a large paid staff. However, we
have discovered a lot of things that had to be changed in the SourceForge code
to make it more usable, and there are still lots of things to be done,
including better documentation, as you point out.

Since Savannah is run by just a few volunteers who spend must of our time
answering user's support requests and reviewing projects that have been
submitted we do not have much time left for development and improvements, so
your recommendations may take a long time to be implemented.

Regarding documentation, Laurent (who has contributed the bug tracking
system) has written a nice manual that is used by the users of a service
similar to Savannah that he maintains at XEROX. The problem with his
documentation is that its source is in a proprietary non-transparent format.
He sent me a plain-text version a few months ago to see if I could transform
it into something useful such as Texinfo, but I haven't have the time to do
it. If you're interest in helping write a Savannah user's guide based on
Laurent's document, let me know and we'll arrange something with Laurent.

On Thu, Sep 19, 2002 at 10:39:48PM +0000, Robert J. Chassell wrote:
>    > Each CVS Introduction page contains instructions for Anonymous CVS
>    > access.  But the instructions contain a bug, at least as tested with a
>    > two accounts that are not mine.
>     ~/test $ cvs
>     login 
>     Logging in to
>     password:  Unknown host

The problem is that you used a double @ instead of a single one. I don't see
any @@ in the CVS Introduction page; was it a typo when you did copy and

>    I never had a .cvspass file on any account on any computer (with
>    several distros, as RedHat, Debian and Mandrake). 

CVS is supposed to create the .cvspass file for you; but I have also seen an
error message complaining about a non-existing .cvspass in some machines. I
should have investigated the issue further and discuss it with the CVS
maintainers, but not having much time to spend on it I've always solved it with
a simple "touch .cvspass" as I guess lots of users have done.

> This worked then.  Now I continue to get a
>     Unknown host
> so my hunch is that subversions is down.  Hmmm.....  Ah ... ,

subversions is fine; but @subversions does not exist (user@@subversions has
been interpreted as "user" at machine "@subversions")

> I just changed to a different ISP, a different account, and now I see the
> following:
>     <guest> ~ $   cvs -d:pserver:address@hidden:/cvsroot/softfree login
>     Logging in to :pserver:address@hidden:2401/cvsroot/softfree
>     CVS password: 
>     <guest> ~ $ 
> It looks to me that either this host and user can resolve subversions
> or that subversions is back up.
No. It is simply that this time you got the subversions name right.

> But someone should also mention that sometimes is
> down or otherwise undetectable by a normal account at a normal site
Sure, for instance when the FSF site gets struck by lightning; but not under
normal conditions :-)

When you think a machine is down or undetectable, it is always
convenient to use ping and traceroute to make sure.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]