[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-users] git push -f

From: Andreas Schwab
Subject: Re: [Savannah-users] git push -f
Date: Fri, 06 Jan 2012 12:06:57 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.92 (gnu/linux)

Miles Bader <address@hidden> writes:

> WTF, I tried to use "git push -f" to savannah, but it wouldn't let me:
>    $ git push -f sv
>    Counting objects: 90, done.
>    Delta compression using up to 4 threads.
>    Compressing objects: 100% (70/70), done.
>    Writing objects: 100% (70/70), 30.27 KiB, done.
>    Total 70 (delta 50), reused 0 (delta 0)
>    remote: error: denying non-fast-forward refs/heads/master (you should pull 
> first)
>    To ssh://
>     ! [remote rejected] master -> master (non-fast-forward)
>    error: failed to push some refs to 
> 'ssh://'
> What setting can I change to allow this?

Would it have worked if you deleted and recreated the branch?


Andreas Schwab, address@hidden
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."

reply via email to

[Prev in Thread] Current Thread [Next in Thread]