[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-users] git push -f

From: Tim Landscheidt
Subject: Re: [Savannah-users] git push -f
Date: Sat, 07 Jan 2012 03:57:29 +0000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)

Andreas Schwab <address@hidden> wrote:

>> WTF, I tried to use "git push -f" to savannah, but it wouldn't let me:

>>    $ git push -f sv
>>    Counting objects: 90, done.
>>    Delta compression using up to 4 threads.
>>    Compressing objects: 100% (70/70), done.
>>    Writing objects: 100% (70/70), 30.27 KiB, done.
>>    Total 70 (delta 50), reused 0 (delta 0)
>>    remote: error: denying non-fast-forward refs/heads/master (you should 
>> pull first)
>>    To ssh://
>>     ! [remote rejected] master -> master (non-fast-forward)
>>    error: failed to push some refs to 
>> 'ssh://'

>> What setting can I change to allow this?

> Would it have worked if you deleted and recreated the branch?

IIRC, I did exactly that (successfully) in 2010.  Was the
configuration changed recently?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]