[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-users] Unable to cvs checkout team's homepage

From: Bob Proulx
Subject: Re: [Savannah-users] Unable to cvs checkout team's homepage
Date: Sun, 24 Sep 2017 19:19:32 -0600
User-agent: NeoMutt/20170609 (1.8.3)

Rafael Fontenelle wrote:
> Assaf Gordon wrote:
> > I just tried this command on two different computers, different networks
> > and it worked fine.

I just tried it to Colorado and it worked okay for me too.  The files
are small at only 1.6M and so this would not be too big.  When I ran
it here the checkout was very fast taking only 2.5 seconds!  Wow!

  cvs -z3 co www-pt-br

> > I'm guessing this was a temporary error on the savannah server (it
> > happens sometimes, especially if it gets overloaded with many people
> > trying to checkout repositories at the same time).

Or something in between.  This doesn't feel like a Savannah problem to
me yet.  Feels like something in between.

> > May I ask you to try again ?
> Just tried again, same result as yesterday, in two different
> residential networks (therefore no special proxy/firewall
> implementations).
> I don't have another computer to test at the moment, but I am able to
> access via SSH the was established (action
> denied, but connection was OK) and also able to cvs-checkout
> anonymously. Could there be any configuration missing?

Since cvs is a high use server at Savannah I think if it weren't
working generally then we would be hearing many problem reports.
Since we aren't and it appears to be working I think we need to focus
on your side of the connection.

I have a couple of different experiments to try.  One is to try the
checkout using the anonymous pserver side of cvs.  To prove that the
path between is okay and to eliminate ssh from the problem.  It can't
be used to check in but will get a full copy of the code the same as
using ssh.

  cvs -z3 -d:pserver:address@hidden:/webcvs/www-pt-br co www-pt-br  

I expect that to work.  It should work.  Works for me and others.  But
will it work for you on your network?  Especially if that works then I
would focus on the ssh side of things.

There are two configuration files typically in use when cvs calls ssh
and it connects.  One is the per user file ~/.ssh/config and the other
is the system /etc/ssh/ssh_config file.  At this point I am most
suspicious of something in one of those files that is causing

Do you have CVS_RSH or any other CVS_* variable set in the
environment?  cvs traditionally defaults to using rsh but on most
systems today rsh is a symlinked alternative to ssh.  This depends
upon your system but if it is using the real rsh then that can't work
as only ssh connections are allowed.  If you have CVS_RSH set to
something that isn't happy then that might be the problem.  Or on your
system you might require setting 'export CVS_RSH=ssh' in order to
force cvs to use ssh.

Please try this:

  env CVS_RSH=ssh cvs -z3 -d:ext:address@hidden:/webcvs/www-pt-br co www-pt-br


reply via email to

[Prev in Thread] Current Thread [Next in Thread]