[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[screen-devel] [bug #33225] screen sometimes dies when started through s

From: Cyril Roussillon
Subject: [screen-devel] [bug #33225] screen sometimes dies when started through ssh -t
Date: Tue, 03 May 2011 18:02:21 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101213 Gentoo Firefox/3.6.13 meandmyself


                 Summary: screen sometimes dies when started through ssh -t
                 Project: GNU Screen
            Submitted by: cyril42e
            Submitted on: Tue 03 May 2011 06:02:18 PM GMT
                Category: Crash/Freeze/Infloop
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 4.0.3
           Fixed Release: None
         Planned Release: None
           Work Required: None



I start commands in screens on distant machines using ssh with -t option,
advertised in ssh man to allow the use of screen. It doesn't work at all
without this option (the command is blocking). For instance with this command

ssh -t <machine> "screen -d -m sleep 100"

- sometimes it doesn't seem to create a screen session (nothing with screen
- sometimes it creates a screen session but which is immediately "Dead",
- sometimes it creates a screen session correctly "Detached", but which never
ends (here after 100s it is supposed to end). When trying to attach it it
freezes, and ctrl-c makes the screen "Dead" with the message "Suddenly the
Dungeon collapses!! - You die...",
-eventually sometimes it just works (creates a "Detached" screen, can attach
it, detach it again, etc).

More interesting, on some machines it almost always works, and on some other
machines it almost never works, even if they have exactly the same OS and
software version, eg:

[~] uname -a
Linux bugsbunny 2.6.18-238.9.1.el5 #1 SMP Tue Apr 12 18:10:13 EDT 2011 x86_64
x86_64 x86_64 GNU/Linux
[~] cat /proc/version 
Linux version 2.6.18-238.9.1.el5 (address@hidden) (gcc version
4.1.2 20080704 (Red Hat 4.1.2-50)) #1 SMP Tue Apr 12 18:10:13 EDT 2011
[~] screen --version
Screen version 4.00.03 (FAU) 23-Oct-06
[~] ssh -v
OpenSSH_5.8p1-hpn13v10, OpenSSL 1.0.0d 8 Feb 2011

I tried with different machines with different OpenSSH versions, from 4.3 to
5.8, in the two directions, and it never worked perfectly. Actually I don't
know if this is a bug of ssh, sshd or screen... Of course it is the same with
other commands than sleep.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]