[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [screen-devel] Why we changed the windows title display schema?

From: Amadeusz Sławiński
Subject: Re: [screen-devel] Why we changed the windows title display schema?
Date: Fri, 21 Oct 2016 18:15:47 +0200

On Fri, 21 Oct 2016 14:58:52 +0800
Bo M <address@hidden> wrote:

> Hi,
> I have used gnu-screen for a few years. And it makes my daily work
> more efficiency. And I love it.
> But in the recent update of version 4.4
> $ screen -v
> Screen version 4.04.00 (GNU) 19-Jun-16
> It changes the windows title displaying scheme. And all the windows
> title are set to `bash`. And I searched over the internet and tried
> many kinds of method, but still cannot make it works as before. So I
> have to downgrade it to an older version 4.3.
> Here is the difference:
> For version 4.3:
> $ C-a "
>    0 address@hidden:~
> $
>    1 address@hidden:~
> $
>    2 address@hidden:~
> $
>    3 address@hidden:~
> $
> For version 4.4:
> $ C-a "
>    0
> bash
> $
>    1
> bash
> $
>    2
> bash
> $
>    3
> bash
> $
> All the windows are shown as `bash` as above, and it makes hard to
> detect which window is running in which working dir or host.
> I am not sure why it has such change which will bring so much
> inconvenient. And I also tried to check the changelog, but
> unfortunately the change logs end at version 4.3.
> Bo.


Here is a list of changes between 4.3.0 and 4.4.0 according to git log:

4c68f0ea9db4727421c7f98cb808f8437db56baa 4.4.0 bump
bfae454059ee3108d753be90f1679a6b692d73c8 Fix more hardcoded termlen
5ecd2b39581286b53d28b291d14554989116990d fix null pointer dereference
in RC_LOGFILE 23c7d0e19972411900efbd59452e5ff7bb5a69fb fix logfile
command so it starts logging to new file
738fefe659c0cf9ef24e2cb9e082c24140cc6f60 fix compile with -DDEBUG
0fae6713ab7dbe0f70538cc9d1d301e83b610ce2 bugfix: vi-style search fails
on long wrapped lines. 4b2a6de31d8992c9055174e7de862604907a967a Global
out of bounds read in termcap.c due to wrong loop
4b12d96b4a770a17ac279a44ec73cedf26ab4e5b Added support for 24 function
keys (ie. up to Shift-F12) 785fef09ea088251e9c5523b5330987b4120b32f fix
impossible if() 1db6b4590418954037f340fc9f394554927d51c4 Use-after-free
01476b764bc91c96848058f69a3d6ae095719e5e remove unused variables xs xe
ys 2e2410a668be96bcd64afbba2fd601c237f5a68e Revert "change checks for
utmp/utmpx in header" 84c15c98ab2e800571062bdb1ac98d215edb0cc3
Partially revert "change checks for utmp/utmpx in header"
cbda6528817e772a5f5b3af2bb67d77cdc9699dc Add trivial definitions of RFC
2292 CMSG_LEN() CMSG_SIZE() bfd4662c36f4a42690ae91df0c21449a5a771a1a
Use realpath(name, buf) for Solaris
b7484c224738247b510ed0d268cd577076958f1b Fix stack overflow due to too
deep recursion 03b85024504fb1e7cea0c289a16bbe887fa86bc9 Fix multijob
build 31a442974be8f16e0007197431e7c371473110ac Remove version number
from INSTALL, README and man page
10a63e7b24e5f98669d309f9398205ceb0c9b136 4.3.1 bump
fdd65811ab0e9d730ec1b9865e76ba99cdc84c6d Update ChangeLog: version
4.3.0 27a8c9677a95b8de67c91f983b25691f0864c194 Fix off by one error
when resizing windows

As far as I can see there is nothing that would explain this behaviour,
can you try building screen yourself and see if ths bug reproduces?
(Releases are available here: )

Other thing you could do is filling bug report in your distribution bug
tracker, many distributions do apply additional patches to official
releases and package maintainer may know better what changes they did.

Otherwise I would try to git bisect, to see if you can locate which
commit broke it. Do note that v4 releases are based on screen-v4 branch.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]