[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[screen-devel] [bug #53602] Screen corruption with some wide glyphs

From: Dave
Subject: [screen-devel] [bug #53602] Screen corruption with some wide glyphs
Date: Tue, 10 Apr 2018 06:42:14 -0400 (EDT)
User-agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3343.0 Safari/537.36


                 Summary: Screen corruption with some wide glyphs
                 Project: GNU Screen
            Submitted by: davewoodfall
            Submitted on: Tue 10 Apr 2018 10:42:12 AM UTC
                Category: Program Logic
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
                 Release: Cur Dev Sources
           Fixed Release: None
         Planned Release: None
           Work Required: None




I'm having a problem with certain characters causing the indentation in the
following lines to be messed up.

I found this problem in 4.6.2 originally, but made a git clone yesterday and
the problem seems to persist.

Screenshot of mutt to show you what I mean:

This does not happen with screen 4.4.0.

I haven't tried any versions between 4.4.0 and 4.6.2, but I have tested in
rxvt-unicode and xfce4-terminal with the same results. VTE based terms like
xfce4-term are usually pretty good at dealing with wide unicode characters.

I am starting screen with -U, tested with no ~/.screenrc and tried a few
different TERM settings to see if it would help. I have also tried a few of
the patches from Debian.

Something seems to have happened between 4.4.0 and 4.6.2, but a diff of the
two is around 17k lines long, so it's hard to sift through.

Thanks in advance for any pointers.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]