[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Invalid message (magic 0x6175472)

From: Cameron Kerr
Subject: Invalid message (magic 0x6175472)
Date: Tue, 1 Feb 2005 15:16:39 +1300

Debian GNU/Linux Testing on x86, kernel 2.4.29 (and priors), Screen version 4.00.02 (FAU) 5-Dec-03

Hello, I'm writing a system that puts a lot of windows (about 12) into a screen session. Sometimes, (ie, not all the time), I find that inside the screen session, I get the following messages

Unknown user /dev/pts/11 tried to send a command!
Invalid message (magic 0x6175472)

The magic in the last message changes, from what I can tell. I'm sure it was 0x000000 at one time, so it seems to be some packet parsing problem or similar. As for the Unknown user line, I don't know why that happens, nor do I get know if its always pts/11.

Anyway, the end result is that some of the windows don't show up inside the screen session.

Thinking it may have something to do with too many windows coming in too close together and dropping off the connection queue, I increased the queue length to listen() to 20, with no difference.

The message is output from this piece of code in ReceiveMsg

  if (m.protocol_revision != MSG_REVISION)
      Msg(0, "Invalid message (magic 0x%08x).",

So it seems that the message is unaligned. I suspect this is due to the first message, and thus there is something left in the buffer.

The first message, regarding the 'Unknown user' message, is produced by the following code.

  user = *FindUserPtr(mp->m.attach.auser);
  if (user == 0)
      Msg(0, "Unknown user %s tried to send a command!",

I'm building it with -DDEBUG now, to have a closer look under the hood.

Any ideas on the cause of this would be most welcome.

Cameron Kerr

reply via email to

[Prev in Thread] Current Thread [Next in Thread]