[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: unknown terminal "screen.linux"

From: Mark Himsley
Subject: Re: unknown terminal "screen.linux"
Date: Fri, 28 Oct 2005 19:25:36 +0100

--On 28 October 2005 10:30:36 -0500 Aaron Griffin <address@hidden> wrote:

On 10/28/05, Mark Himsley <address@hidden> wrote:
> Hello,
> I have been using the excellent Screen window manager for many years and
> have been exceedingly happy with it.
> Up until 6 months ago I had been using a RedHat 9 as the main server I
> ssh into. On it I tried to keep a `screen` running with some windows
> sshed into other servers, to give me a central perpetual connection to
> these other servers. This worked very well and I had no problems - it
> was using:
> $ screen --version
> Screen version 3.09.13 (FAU) 5-Sep-02
> Six months ago I bought a faster machine and installed Fedora Core 3. I
> tried to setup the same arrangement but I am getting some problems with
> the terminal environment - the FC3 machine is using:
> $ screen --version
> Screen version 4.00.02 (FAU) 5-Dec-03
> Which I *think* is the latest version.
> If I am using a screen window on the FC3 machine and I ssh to, for
> instance, a Redhat 9 server I get the following error:
> $ ssh address@hidden
> unknown terminal "screen.linux"
> unknown terminal "screen.linux"
> and the terminal does not behave correctly.
> If instead I enter the command:
> $ TERM=screen ssh address@hidden
> then everything works well.
> > From the man page I was under the impression that:
> "When screen tries to figure out a terminal name for itself, it first
> looks for an entry named "screen.<term>", where  <term> is the contents
> of your $TERM variable. If no such entry exists, screen tries "screen"
> (or "screen-w" if the terminal is wide (132 cols or more)). If even
> this entry cannot be found, "vt100" is used as a substitute."
> When I ssh into the FC3 machine my $TERM variable is 'linux'. When I
> invoke Screen it is turning that into 'screen.linux'. When I ssh to
> another machine I though that Screen would try 'screen.linux', 'screen'
> and 'vt100' to try to get a valid terminal type.
> It appears to me that Screen 4.00.02 is not trying either the 'screen'
> or the 'vt100' substitutes.
> It it me - is there some configuration that I have failed to set in my
> ~/.screenrc that would get over this problem?
> My current solution is to add this to /etc/profile
> if [ "$TERM" = "screen.linux" ]; then
>         TERM="screen"
>         export TERM
> fi
> This gets over the problem but it feels like there aught to be a more
> elegant solution. Alternatively I've got completely the wrong end of the
> stick.
> Thanks for your time.
> --
> Mark Himsley

What terminal are you using screen in initially?  That should be
responsible for the TERM variable.  For instance, if I am in
rxvt-unicode (which I usually am), and I ssh to one of my servers, I
get the same unknown terminal messages for "rxvt-unicode".

Initially I use SecureCRT or PuTTY on Windows to SSH to the linux server.

In SCRT the terminal type is set to 'linux' with ANSI colour, and at the initial terminal on the FC3 linux box the value of $TERM is 'linux'.

If I ssh from PuTTY the initial terminal on the FC3 linux box has the $TERM value of 'xterm'.

After I execute `screen` the value of $TERM is 'screen.linux' no matter whether I am using SCRT or PuTTY as the originating terminal emulator.

PS. I hope it isn't bad form for me to reply without removing all the quoting.

Mark Himsley

reply via email to

[Prev in Thread] Current Thread [Next in Thread]