[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Xterm OSC not working inside screen

From: Dennis McGregor
Subject: Re: Xterm OSC not working inside screen
Date: Mon, 8 May 2006 15:00:19 +1000
User-agent: Mutt/1.5.11+cvs20060403

[08.05.06 05:38] Nikolai Weibull <address@hidden> wrote:
> Yes, I've tried

> termcapinfo xterm* XT

> in my screenrc, but it still doesn't work.

> Am I missing something here?

> I'm "echo -n"-ing "^[]4;1;?^[\", which works fine inside an xterm, but
> not inside a screen.

> (What I'm trying to achieve is to get the value of a given color in xterm.)

> Thanks.

>  nikolai

$ echo -n "\eP\e]4;1;?\007\e\\" 
works for me.

from the manual: Virtual Terminal->Control Sequences:
     ESC P  (A)     Device Control String
                    Outputs a string directly to the host
                    terminal without interpretation.

and I'm not sure why, but while in xterm this works when ending the string with 
either BEL ( \007 ) *or* ST ( \e\ ), in screen it seems to require both...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]