[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: screen-256color terminfo entry?

From: cga2000
Subject: Re: screen-256color terminfo entry?
Date: Tue, 16 May 2006 18:29:08 -0400
User-agent: Mutt/1.5.6+20040907i

On Tue, May 16, 2006 at 04:00:55AM EDT, Stephane Chazelas wrote:
> On Mon, May 15, 2006 at 10:34:46PM -0400, cga2000 wrote:
> [...]
> > > Nikolai's entry is:
> > > 
> > > screen-256color|VT 100/ANSI X3.64 virtual terminal,
> > >         am, km, mir, msgr, xenl,
> > >         cols#80, it#8, lines#24, colors#256, pairs#32767,
> > >         bel=^G, blink=\E[5m, bold=\E[1m, cbt=\E[Z,
> > >         clear=\E[H\E[J, cr=\r, csr=\E[%i%p1%d;%p2%dr,
> > >         cub=\E[%p1%dD, cub1=\b, cud=\E[%p1%dB, cud1=\n,
> > >         cuf=\E[%p1%dC, cuf1=\E[C, cup=\E[%i%p1%d;%p2%dH,
> > >         cuu=\E[%p1%dA, cuu1=\EM, dch=\E[%p1%dP, dch1=\E[P,
> > >         dl=\E[%p1%dM, dl1=\E[M, ed=\E[J, el=\E[K, el1=\E[1K,
> > >         enacs=\E(B\E)0, home=\E[H,
> > >         ht=\t, hts=\EH, ich=\E[%p1%d <at> , il=\E[%p1%dL, il1=\E[L,
>                                           ^
>                             should be a @

fixed that (and got rid of the "<" and ">". That's what was causing the
problem with Ctrl+R in the bash shell.
> > >         ind=\n, is2=\E)0, kcub1=\EOD, kcud1=\EOB,
> > >         kcuf1=\EOC, kcuu1=\EOA, kdch1=\E[3~, kf1=\EOP,
> > >         kf10=\E[21~, kf11=\E[23~, kf12=\E[24~, kf2=\EOQ,
> > >         kf3=\EOR, kf4=\EOS, kf5=\E[15~, kf6=\E[17~,
> > >         kf7=\E[18~, kf8=\E[19~, kf9=\E[20~, khome=\E[1~, kend=\E[4~,
> > >         kich1=\E[2~, knp=\E[6~, kpp=\E[5~, nel=\EE,
> > >         rc=\E8, rev=\E[7m, ri=\EM, rmcup=\E[?1049l, rmir=\E[4l,
> > >         rmkx=\E[?1l\E>, rmso=\E[23m, rmul=\E[24m, rs2=\Ec, sc=\E7,
> > >         sgr0=\E[m, smcup=\E[?1049h, smir=\E[4h, smkx=\E[?1h\E=,
> > >         smso=\E[3m, smul=\E[4m, tbc=\E[3g, smacs=^N, rmacs=^O, flash=\Eg,
> > >         civis=\E[?25l, cnorm=\E[34h\E[?25h, cvvis=\E[34l,
> > >         op=\E[39;49m, setab=\E[48;5;%p1%dm, setaf=\E[38;5;%p1%dm,
> > >         
> > > acsc=``aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++\054\054hhII00,
> > 
> > Nikolai's entry corrects the mutt/weechat display issue and causes man +
> > less/most's output to be correctly formatted - as far as I can tell.
> could be bce then. You probably don't have bce enabled in
> screen, so that it matches Nikolai's entry. But that's not
> optimal given that xterm has bce. You could try
> <Ctrl-A>:bce on

That did the trick..! 

I tried to add it to my .screenrc:

bce on

.. but this apparently doesn't work - I get an error message at startup
telling me that "bce: window required" and I still have to enter it via
"Ctrl+A :"

I checked the screen manual and the bce command only has one parameter
which should be "on" or "off" so I am unsure what I am doing wrong.

At a different level, I'm rather confused as to the logic of this,
though. I thought that terminfo/termcap entries in the screen .rc file
were only to override or complement the terminal entry. But in this
instance we are repeating it? 
> with my terminfo entry and see if that fix things. I still don't see
> why it would for less though.

It doesn't. It only fixes the mutt/weechat truncated highlit line
> would you have screen shots of the problem?

..first page of "man xterm" on my display with the three pagers I
tested. This was done with a your terminfo entry (unmodified) and after
issuing a ":bce on" command to screen.
> What does appres XTerm give you?

a sh*tload of resources.. :-) 

..defaults, I guess & some hopefully harmless stuff defined by myself -
mostly fonts and colors.

What did you have in mind?
> > But so far it has caused the following problems:
> > 
> > 1. the bash Ctrl+R (search history) command does not function
> > correctly. I hit Ctrl+R and for each character I enter I see a "t >"
> > overlaying the bash prompt and the command currently selected by the
> > incremental search is not visible. ehich makes it unusable - for all I
> > know the selected command could be an "rm" command that I absolutely do
> > not want to (re-)execute.
> Probably due to that <at> thing above when I copy pasted from
> the site where Nikolai indicated his entry was. 
> [...]
> > Well, I'd say that this is the only useful part of my modest findings:
> > The two problems I was experiencing with your terminfo entry - and
> > xterm-256color regarding the "truncated highlights" - are fixed by his
> > screen-256color. But as mentioned above it introduces at least two
> > other (more serious, imo) problems. 
> > 
> > My personal feeling is that I should modify your (more complete)
> > screen-256color to fix my two problems but I honestly have no idea how
> > this should be done. And using the diff's to randomly change your
> > terminfo entry without a clue what I am looking for does not sound
> > like realistic approach. 
> > 
> > On the other hand considering all the trouble you have taken over this I
> > am quite willing to make any changes you suggest and run more tests
> > until I get this right - the problem being that I have zero experience
> > with terminfo.
> [...]
> Try the bce thing.

fixes the truncation issue as mentioned above.
> Mine is missing the el1 (clear to beg-of-line).
> See man 5 terminfo
> for the details.

I added that one - copied Nikolai's - but it doesn't make any difference
as far as I can tell.
> To edit a terminfo entry:
> infocmp <entry> > file vi file sudo tic file # or use export
> TERMINFO=~/.terminfo # if you don't have root access.
.. and even if you do, I guess it's much cleaner doing it this way while
experimenting. Thanks for the tip..!
> I'll double check my entry to see if everything makes sense, when I
> have some time.

No rush at all.  Thanks to this thread I have already made excellent
progress.  For now I can alias man to something like "TERM=other_term
man" so the output is legible.

I tried this and strangely enough I get a nasty message from - man I
guess? informing me that the "terminal is not fully functional" ..
Press Enter .. And sure enough line erase keys such as Ctrl+U and
Ctrl+K stop functioning. Annoying because it doesn't happen when I
issue the same "TERM=.. man xterm" typing the whole thing at the prompt
instead of aliasing. Weird.

Well, thank you very much for your help and I hope you will have some
idea what I am doing wrong.. In the meantime I'll try to figure out
stuff from the terminfo 5 man page.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]