[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Can't send newline

From: Ariel Frailich
Subject: Can't send newline
Date: Tue, 4 Jul 2006 21:44:48 -0400


I'm trying to send a string to the modem from a script, using <screen -S myscreen -X stuff "string%n">. The problem is that I can't get the newline character across: it just echoes exactly as I send it. I've tried ^m, ^M, %n, %r, \015 and various other octal characters, but to no avail.

Just to be clear: I have two terminal windows, one is running screen, the other has a command line. If I type <screen -S myscreen -X stuff "ATH0%n"> at the command line, the other windows shows <ATH0%n>; nothing is sent to the modem unless I press return in that window. The same is true for all other newline variations. I tried everything I found on this list that worked for others, but none of it is working for me (e.g., the thread on sending an ESC across, even using <screen -S myscreen -X stuff `echo -ne '%n'`>).

I'm running screen 4.00.02 (FAU) 5-Dec-03, on an iMac Core Duo with OS X 10.4.6. Am I doing something wrong? Does screen work differently on a Mac? Am I misunderstanding something?

Thank you very much for any help, info, advice, etc.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]