[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Weird issue trying to detach/reattach (screen "hangs")

From: Ray Van Dolson
Subject: Weird issue trying to detach/reattach (screen "hangs")
Date: Sat, 4 Aug 2007 08:24:21 -0700
User-agent: Mutt/1.5.15 (2007-04-06)

Had an odd issue this morning with screen 4.0.2 (included with
CentOS/RHEL 4).  Woke up, grabbed my laptop and started using a
terminal connected to my CentOS server with an active screen session
running.  All was well.

However, my wireless connection had been acting funky, so I got up and
reset my wireless router.... while it was rebooting I sat down at my
desktop PC and opened a connection to my CentOS server and ran my usual
'screen -dr' to detach the session that had been running from my

The command didn't complete -- just sat there hanging forever until I
CTRL-C'd out.  Hum.  The SCREEN process was still running and didn't
appear to be deadlocked or anything, but all its child processes
appeared to be frozen.  One of the subprocesses was an irssi client and
I noticed this client disconnected from my IRC server shortly after my

Went back my laptop after the wireless router had been rebooted,
reconnected to my server and also tried to screen -d and screen -r.. no
go... the command just hung.

Finally I ran an strace -p on the parent SCREEN process, and suddenly
everything just began magically working again!

Does anyone know what exactly happened here?  Clearly the signal from
strace "woke" SCREEN up and I could then reattach/attach the session.
But why was it frozen to begin with?  Obviously I didn't log out nor
detach my original session properly, but this shouldn't result in a
locked SCREEN.

Anyways, after a brief Google search I couldn't find the right
combination of keywords or no one else has had this happen.  I know how
to workaround it now... but maybe someone can shed some light on it for
me :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]