[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Strange lock problem under screen 4.00.02/03

From: Steve Phillips
Subject: Re: Strange lock problem under screen 4.00.02/03
Date: Tue, 11 Dec 2007 14:20:56 +1100
User-agent: Thunderbird (Windows/20071031)

Michael Parson wrote:
On Mon, 10 Dec 2007, Steve Phillips wrote:

Hey there,

Intermittently, I have been experiencing a strange problem with screen locking up

Most of the times I find a screen 'locked up' it turns out to be a
flow-control problem.  Some how, a CTRL-S (xoff) has been sent to the
terminal, given the proximity of the S key to the A key (at least on a
QWERTY layout), I can see how a quick fat-fingering might cause this
to occur.  Since I rarely do things over a 2400 bps dial-up any more,
I try and turn flow-control off as much as I can (defflow off in my
.screenrc and the first around of windows opened in the .screenrc have a
-fn in their call), but sometimes things still get stuck.  Before I give
up completely, I try a '^A : xon' or a cycle between '^A : xoff' then
another '^A : xon' and that usually frees things up, but sometimes, it's
just lost and there's nothing I have found to make it go again.

Yup, which was my initial thoughts as well, except this can happen when screen is detached and is reattached with a screen -r

It has happened when i've been in the middle of scrolling back using page up/down

It has happened when I've killed the locked window and the next one in line (an empty bash shell that was previously responding) locks up as well (this has happened for anything other than bash as well)

I've also tried to turn off flow control and have tried issuing an XON as well to no avail.

The interesting thing, was, when attaching the strace to the primary screen process itself that also seemed hung - and, while screen had been detached since my previous mail - it has since started to respond again.

Someone mentioned that excess dead ssh sessions seem to cause this and removing them can sometimes free screen up - I have no idea why this is the case but apparently according to a number of other people that have experienced similar 'hung' sessions - this also seems to work, I'll wait for it to freeze again then try that :-)

(I wonder if this could be something to do with re-attaching using screen -x rather than screen -dr and the 'dead ssh' pty locking up, hence filling the write buffer ? - just a completely un-educated guess)

()  ascii ribbon campaign - against html e-mail
/\   - against proprietary attachments

reply via email to

[Prev in Thread] Current Thread [Next in Thread]